Bug 1240654 - quota: allowed to set soft-limit %age beyond 100%
Summary: quota: allowed to set soft-limit %age beyond 100%
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1244724
TreeView+ depends on / blocked
 
Reported: 2015-07-07 12:35 UTC by Manikandan
Modified: 2016-09-20 04:29 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1064265
: 1244724 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:21:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Manikandan 2015-07-07 12:35:29 UTC
+++ This bug was initially created as a clone of Bug #1064265 +++

Description of problem:
allowed to set the soft-limit percentage more than 100%

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.59rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a volume, start it
2. enable quota
3. mount over nf
4. create a directory inside the mount point
5. gluster volume quota limit-usage /dir-name <size> <soft-limit-percentage>
define soft-limit percentage as 100%

Actual results:

step5 result,

[root@quota6 ~]# gluster vol quota dist-rep2 limit-usage /dir8 5GB 650%
volume quota : success


Expected results:

should not cross 100%

Additional info:

Comment 1 Anand Avati 2015-07-07 13:15:36 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 2 Anand Avati 2015-07-08 05:37:15 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 3 Anand Avati 2015-07-08 11:54:07 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage.) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 4 Anand Avati 2015-07-09 03:55:18 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage.) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 5 Anand Avati 2015-07-09 07:13:00 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 6 Anand Avati 2015-07-09 09:45:12 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 7 Anand Avati 2015-07-09 09:50:25 UTC
REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage.) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 8 Nagaprasad Sathyanarayana 2015-10-25 15:11:08 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 9 Niels de Vos 2016-06-16 13:21:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.