Bug 1244724 - quota: allowed to set soft-limit %age beyond 100%
Summary: quota: allowed to set soft-limit %age beyond 100%
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On: 1240654
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-20 11:24 UTC by Manikandan
Modified: 2016-09-20 04:28 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1240654
Environment:
Last Closed: 2015-09-09 09:38:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Manikandan 2015-07-20 11:24:30 UTC
+++ This bug was initially created as a clone of Bug #1240654 +++

+++ This bug was initially created as a clone of Bug #1064265 +++

Description of problem:
allowed to set the soft-limit percentage more than 100%

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.59rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a volume, start it
2. enable quota
3. mount over nf
4. create a directory inside the mount point
5. gluster volume quota limit-usage /dir-name <size> <soft-limit-percentage>
define soft-limit percentage as 100%

Actual results:

step5 result,

[root@quota6 ~]# gluster vol quota dist-rep2 limit-usage /dir8 5GB 650%
volume quota : success


Expected results:

should not cross 100%

Additional info:

--- Additional comment from Anand Avati on 2015-07-07 09:15:36 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-08 01:37:15 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-08 07:54:07 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage.) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-08 23:55:18 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage.) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 03:13:00 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 05:45:12 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 05:50:25 EDT ---

REVIEW: http://review.gluster.org/11566 (quota : validating soft limit percentage.) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 1 Anand Avati 2015-07-20 11:32:39 UTC
REVIEW: http://review.gluster.org/11723 (quota : validating soft limit percentage) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 2 Anand Avati 2015-07-21 11:21:15 UTC
REVIEW: http://review.gluster.org/11723 (quota : validating soft limit percentage) posted (#2) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 3 Anand Avati 2015-08-11 06:18:54 UTC
REVIEW: http://review.gluster.org/11723 (quota : validating soft limit percentage) posted (#3) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 4 Anand Avati 2015-08-11 06:26:39 UTC
REVIEW: http://review.gluster.org/11723 (quota :validating soft limit percentage) posted (#4) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 5 Anand Avati 2015-08-12 10:49:33 UTC
COMMIT: http://review.gluster.org/11723 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit e7904592678d58123fd12c58dad5a95b4e8031cd
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Jul 7 18:37:42 2015 +0530

    quota :validating soft limit percentage
    
            Backport of http://review.gluster.org/#/c/11566/
    
    Cherry-picked from commit bc6110fa37f1d6214d2e8cce367e0b7abd6976c3
    > Change-Id: I14c049c84c468b6415a1de45441b2fed94e8ed4b
    > BUG: 1240654
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/11566
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I14c049c84c468b6415a1de45441b2fed94e8ed4b
    BUG: 1244724
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/11723
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 6 Kaushal 2015-09-09 09:38:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.