Bug 124072 - Licq KDE plugin does not work.
Licq KDE plugin does not work.
Status: CLOSED DUPLICATE of bug 182733
Product: Fedora
Classification: Fedora
Component: licq (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Depends On:
  Show dependency treegraph
Reported: 2004-05-23 16:16 EDT by Jan Hilberath
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-21 11:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wtogami: fedora‑cvs+

Attachments (Terms of Use)

  None (edit)
Description Jan Hilberath 2004-05-23 16:16:36 EDT
Description of problem:
Licq uses the qt-gui when started with "-p kde-gui". 

This is because the configure script does not detect the KDE libraries 
during build. The kde-gui plugin (licq_kde-gui.so) does not get built, 
only the standard qt-gui (licq_qt-gui.so) gets build.

The RPM spec file handles this by just copying licq_qt-gui to 
licq_kde-gui. So even when explicitely starting the kde-gui, qt-gui 
binaries will be used.

Running "./configure --with-kde" shows, that the script does not detect 
the KDE libraries:
checking for KDE includes...  /usr/include/kde
checking for KDE libraries... no

This is because it cannot find the file "libkdecore.la" in
$kde_libdirs. It's located in "/usr/lib64", so appending this
to $kde_libdirs in the configure script manually or setting "KDEDIR" 
before calling the script will work:
"KDEDIR=/usr/lib64 ./configure --with-kde"

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start Licq with KDE GUI.

Actual Results:  Licq starts with QT GUI.

Expected Results:  Licq should start with KDE GUI.

Additional info:
Comment 1 John Thacker 2006-04-21 11:39:24 EDT
If you can believe it, this got fixed in licq in Fedora Extras recently.  It's a
duplicate of Bug 182733
licq not finding the right path for plugins on x86_64.
Marking as duplicate.

*** This bug has been marked as a duplicate of 182733 ***
Comment 2 Jiri Moskovcak 2007-07-09 08:45:18 EDT
Package Change Request
Package Name: licq
Updated Fedora Owners: jmoskovc@redhat.com

Note You need to log in before you can comment on or make changes to this bug.