Bug 182733 - licq (I think only x64_86-Version) uses the wrong lib-path for plugins
licq (I think only x64_86-Version) uses the wrong lib-path for plugins
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: licq (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
: 124072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 07:15 EST by Florian Erfurth
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-03 10:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian Erfurth 2006-02-24 07:15:47 EST
Description of problem:
The licq-binary of the x64_86-package uses the wrong library-path. (it uses the
lib-directory instead of lib64-directory) So licq doesn't find the lib for
plugins (for Example GUI-plugin)

Version-Release number of selected component (if applicable):
licq-1.3.2-4

How reproducible:
Always.

Steps to Reproduce:
1. start licq with following command:
licq -p kde-gui
  
Actual results:
I get following error:
>>>
13:14:12: [ERR] Unable to load plugin (qt-gui): /usr/lib/licq/licq_kde-gui.so:
Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden.
<<<
translation for non German:
Couldn't load shared object file: file or directory not found.

Expected results:
Start licq with loaded plugins in /usr/lib64/licq/*.

Additional info:
I already installed the package licq-kde
The plugin-path should be corrected from /usr/lib/licq to /usr/lib64/licq

Workaround till fix:
ln -s /usr/lib64/licq /usr/lib/licq

cu Floh
Comment 1 Peter Vrabec 2006-03-03 10:35:42 EST
This problem should be fixed with licq-1.3.2-5.FC4 and licq-1.3.2-6
Comment 2 John Thacker 2006-04-21 11:39:26 EDT
*** Bug 124072 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.