Bug 1240917 - VMRC fails with firefox browser in Linux OS with the error "Unable to connect to the MKS: Failed to connect to server <server>:<port>"
Summary: VMRC fails with firefox browser in Linux OS with the error "Unable to connect...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.6.0
Assignee: Brian McLaughlin
QA Contact: Ramesh A
URL:
Whiteboard: vmrc:browser
Depends On:
Blocks: 1291699
TreeView+ depends on / blocked
 
Reported: 2015-07-08 06:37 UTC by Ramesh A
Modified: 2016-06-29 14:58 UTC (History)
6 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1291699 (view as bug list)
Environment:
Last Closed: 2016-06-29 14:58:12 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
VMRC ERROR (52.10 KB, image/png)
2015-07-08 06:37 UTC, Ramesh A
no flags Details
VMRC- Developer tools console details (84.59 KB, image/png)
2015-07-08 06:38 UTC, Ramesh A
no flags Details
vmrc-sourceFileMap-error.png (69.99 KB, image/png)
2015-11-23 12:13 UTC, Ramesh A
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Ramesh A 2015-07-08 06:37:41 UTC
Created attachment 1049714 [details]
VMRC ERROR

Description of problem:
VMRC fails with firefox browser in Linux OS with the error "Unable to connect to the MKS: Failed to connect to server <server>:<port>"

Version-Release number of selected component (if applicable):
5.3.4.2.20150415125246_f5d5c91

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Infrastructure ==> Virtual Machines
2. Click on the VMRC icon


Actual results:
Fails with following message "Unable to connect to the MKS: Failed to connect to server 10.8.58.22:902".  No error found in the production.log file nor in evm.log file.  Refer the screenshot for more details

Ps:
1. Works fine with firefox in Windows 7
2. Fails only Linux environment

Expected results:
Should work properly

Additional info:

production.log:
===============
[----] I, [2015-07-08T02:22:10.794098 #2220:843014]  INFO -- : Started POST "/vm_infra/vmrc_console/278" for 127.0.0.1 at 2015-07-07 22:22:10 -0400
[----] I, [2015-07-08T02:22:10.797266 #2220:843014]  INFO -- : Processing by VmInfraController#vmrc_console as JS
[----] I, [2015-07-08T02:22:10.797376 #2220:843014]  INFO -- :   Parameters: {"id"=>"278"}
[----] I, [2015-07-08T02:22:10.847970 #2220:843014]  INFO -- : Completed 200 OK in 50.4ms (Views: 1.3ms | ActiveRecord: 7.1ms)
[----] I, [2015-07-08T02:22:12.383650 #2220:843014]  INFO -- : Started POST "/vm_infra/wait_for_task?task_id=68" for 127.0.0.1 at 2015-07-07 22:22:12 -0400
[----] I, [2015-07-08T02:22:12.389381 #2220:843014]  INFO -- : Processing by VmInfraController#wait_for_task as JS
[----] I, [2015-07-08T02:22:12.389551 #2220:843014]  INFO -- :   Parameters: {"authenticity_token"=>"8gNy34nhetvd3rkQ3x6QNRJ+u1JDypRGQEMXgx8e0yg=", "task_id"=>"68"}
[----] I, [2015-07-08T02:22:12.415169 #2220:843014]  INFO -- : Completed 200 OK in 25.4ms (Views: 1.2ms | ActiveRecord: 1.2ms)
[----] I, [2015-07-08T02:22:14.692013 #2220:843014]  INFO -- : Started POST "/vm_infra/wait_for_task?task_id=68" for 127.0.0.1 at 2015-07-07 22:22:14 -0400
[----] I, [2015-07-08T02:22:14.695260 #2220:843014]  INFO -- : Processing by VmInfraController#wait_for_task as JS
[----] I, [2015-07-08T02:22:14.695354 #2220:843014]  INFO -- :   Parameters: {"authenticity_token"=>"8gNy34nhetvd3rkQ3x6QNRJ+u1JDypRGQEMXgx8e0yg=", "task_id"=>"68"}
[----] I, [2015-07-08T02:22:14.841609 #2220:843014]  INFO -- : Completed 200 OK in 146.0ms (Views: 1.3ms | ActiveRecord: 1.5ms)
[----] I, [2015-07-08T02:22:16.863978 #2220:843014]  INFO -- : Started POST "/vm_infra/wait_for_task?task_id=68" for 127.0.0.1 at 2015-07-07 22:22:16 -0400
[----] I, [2015-07-08T02:22:16.869718 #2220:843014]  INFO -- : Processing by VmInfraController#wait_for_task as JS
[----] I, [2015-07-08T02:22:16.869891 #2220:843014]  INFO -- :   Parameters: {"authenticity_token"=>"8gNy34nhetvd3rkQ3x6QNRJ+u1JDypRGQEMXgx8e0yg=", "task_id"=>"68"}
[----] I, [2015-07-08T02:22:16.913100 #2220:843014]  INFO -- : Completed 200 OK in 43.0ms (Views: 1.2ms | ActiveRecord: 3.6ms)
[----] I, [2015-07-08T02:22:17.777106 #2220:843014]  INFO -- : Started GET "/vm_infra/launch_vmware_console/278" for 127.0.0.1 at 2015-07-07 22:22:17 -0400
[----] I, [2015-07-08T02:22:17.780301 #2220:843014]  INFO -- : Processing by VmInfraController#launch_vmware_console as HTML
[----] I, [2015-07-08T02:22:17.780388 #2220:843014]  INFO -- :   Parameters: {"id"=>"278"}
[----] I, [2015-07-08T02:22:17.816467 #2220:843014]  INFO -- :   Rendered vm_common/_console_vmrc.html.erb (3.7ms)
[----] I, [2015-07-08T02:22:17.816682 #2220:843014]  INFO -- :   Rendered vm_infra/console.html.erb within layouts/application (4.1ms)
[----] I, [2015-07-08T02:22:17.818660 #2220:843014]  INFO -- : Completed 200 OK in 38.1ms (Views: 5.3ms | ActiveRecord: 3.0ms)
[----] I, [2015-07-08T03:10:29.126714 #22012:96b810]  INFO -- : Connecting to database specified by database.yml

Comment 1 Ramesh A 2015-07-08 06:38:29 UTC
Created attachment 1049715 [details]
VMRC- Developer tools console details

Comment 5 Ramesh A 2015-11-23 12:13:48 UTC
Created attachment 1097626 [details]
vmrc-sourceFileMap-error.png

Comment 7 Ramesh A 2015-11-26 12:07:40 UTC
Brian,

I have sent you an email with the details of the appliance ip and win7 vm.  I have successfully logged into vmrc in FF / IE in Win7.

Let me know if you need any further assistance.

Thanks,
Ramesh

Comment 9 Ramesh A 2016-04-25 06:52:02 UTC
Verification blocked due to BZ#1329940

Comment 11 errata-xmlrpc 2016-06-29 14:58:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.