Bug 1240949 - quota: In enforcer, caching parents in ctx during build ancestry is not working
Summary: quota: In enforcer, caching parents in ctx during build ancestry is not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1245448 1248325
TreeView+ depends on / blocked
 
Reported: 2015-07-08 08:35 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:21 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1245448 1248325 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:21:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2015-07-08 08:35:30 UTC
In build ancestry, we get the list of parents for a file. These parents are cached in inode ctx.
This caching is not happening because posix is not setting d_stat information in the leaf node entry.

Comment 1 Anand Avati 2015-07-08 08:36:55 UTC
REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-07-22 03:40:07 UTC
REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-07-22 03:43:56 UTC
REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2015-07-22 05:30:28 UTC
REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Anand Avati 2015-07-22 06:14:06 UTC
REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Anand Avati 2015-07-23 03:57:28 UTC
REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Anand Avati 2015-07-30 03:59:01 UTC
COMMIT: http://review.gluster.org/11574 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit de3023c8b5ded9c82414eec153fc660f568b688e
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jul 22 09:02:39 2015 +0530

    quota: fix parents caching during build ancestry
    
    In build ancestry, we get the list of parents for a file,
    these parents are cached in inode ctx.
    This caching is not happening because posix is not setting
    d_stat information in the leaf node entry
    This patch fixes the issue
    
    Inode-ctx is not updated with new parent when
    rename performed on same directory.
    This patch fixes the issue
    
    There is a possibility of caching stale entries,
    consider below example:
    1) build_ancestry invoked on a file
    2) rename is invoked on the same file
    3) buils_ancestry prepared entries of old parent
    4) rename completed and in cbk old parent is replaced with
           new parent in inode ctx
    5) now build_ancestry cbk adds old parent to inode ctx
    
    In this patch we also remove stale entries in writev and fallocate
    
    Change-Id: Ib1854a41b47b14eb775326588352015c83d034de
    BUG: 1240949
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11574
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 8 Nagaprasad Sathyanarayana 2015-10-25 15:07:14 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 9 Niels de Vos 2016-06-16 13:21:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.