Bug 1248325 - quota: In enforcer, caching parents in ctx during build ancestry is not working
quota: In enforcer, caching parents in ctx during build ancestry is not working
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1240949
Blocks: 1245448
  Show dependency treegraph
 
Reported: 2015-07-30 01:42 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240949
Environment:
Last Closed: 2015-09-09 05:38:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-07-30 01:42:47 EDT
+++ This bug was initially created as a clone of Bug #1240949 +++

In build ancestry, we get the list of parents for a file. These parents are cached in inode ctx.
This caching is not happening because posix is not setting d_stat information in the leaf node entry.

--- Additional comment from Anand Avati on 2015-07-08 04:36:55 EDT ---

REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-21 23:40:07 EDT ---

REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-21 23:43:56 EDT ---

REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-22 01:30:28 EDT ---

REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-22 02:14:06 EDT ---

REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-22 23:57:28 EDT ---

REVIEW: http://review.gluster.org/11574 (quota: fix parents caching during build ancestry) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-07-29 23:59:01 EDT ---

COMMIT: http://review.gluster.org/11574 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit de3023c8b5ded9c82414eec153fc660f568b688e
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jul 22 09:02:39 2015 +0530

    quota: fix parents caching during build ancestry
    
    In build ancestry, we get the list of parents for a file,
    these parents are cached in inode ctx.
    This caching is not happening because posix is not setting
    d_stat information in the leaf node entry
    This patch fixes the issue
    
    Inode-ctx is not updated with new parent when
    rename performed on same directory.
    This patch fixes the issue
    
    There is a possibility of caching stale entries,
    consider below example:
    1) build_ancestry invoked on a file
    2) rename is invoked on the same file
    3) buils_ancestry prepared entries of old parent
    4) rename completed and in cbk old parent is replaced with
           new parent in inode ctx
    5) now build_ancestry cbk adds old parent to inode ctx
    
    In this patch we also remove stale entries in writev and fallocate
    
    Change-Id: Ib1854a41b47b14eb775326588352015c83d034de
    BUG: 1240949
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11574
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Anand Avati 2015-07-30 01:44:03 EDT
REVIEW: http://review.gluster.org/11799 (quota: fix parents caching during build ancestry) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-03 00:04:47 EDT
COMMIT: http://review.gluster.org/11799 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 998a63357cb186953d0eedf5a06bc4ac5594674d
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jul 22 09:02:39 2015 +0530

    quota: fix parents caching during build ancestry
    
    This is a backport of http://review.gluster.org/#/c/11574/
    
    In build ancestry, we get the list of parents for a file,
    these parents are cached in inode ctx.
    This caching is not happening because posix is not setting
    d_stat information in the leaf node entry
    This patch fixes the issue
    
    Inode-ctx is not updated with new parent when
    rename performed on same directory.
    This patch fixes the issue
    
    There is a possibility of caching stale entries,
    consider below example:
    1) build_ancestry invoked on a file
    2) rename is invoked on the same file
    3) buils_ancestry prepared entries of old parent
    4) rename completed and in cbk old parent is replaced with
           new parent in inode ctx
    5) now build_ancestry cbk adds old parent to inode ctx
    
    In this patch we also remove stale entries in writev and fallocate
    
    > Change-Id: Ib1854a41b47b14eb775326588352015c83d034de
    > BUG: 1240949
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/11574
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I26a196e7eeed343593bea3a0b7b51d7be12500a3
    BUG: 1248325
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11799
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2015-09-09 05:38:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.