Bug 1241133 - nfs-ganesha: execution of script ganesha-ha.sh throws a error for a file
Summary: nfs-ganesha: execution of script ganesha-ha.sh throws a error for a file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: common-ha
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1224610
Blocks: 1202842 1241134
TreeView+ depends on / blocked
 
Reported: 2015-07-08 14:16 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 13:22 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1224610
: 1241134 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:22:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-08 14:18:54 UTC
REVIEW: http://review.gluster.org/11581 (common-ha: ganesha-ha.sh status tries to read ganesha-ha.conf) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Anand Avati 2015-07-09 15:01:43 UTC
COMMIT: http://review.gluster.org/11581 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ea7161bca1c9e0c91148fea8895041a08ed24830
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Jul 8 10:14:40 2015 -0400

    common-ha: ganesha-ha.sh status tries to read ganesha-ha.conf
    
    status doesn't need to read the config
    
    Change-Id: Id02252abe52820dbc263f4a880bde72a23b121bd
    BUG: 1241133
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11581
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:15:12 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:22:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.