Bug 1241134 - nfs-ganesha: execution of script ganesha-ha.sh throws a error for a file
Summary: nfs-ganesha: execution of script ganesha-ha.sh throws a error for a file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: common-ha
Version: 3.7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1224610 1241133
Blocks: 1202842
TreeView+ depends on / blocked
 
Reported: 2015-07-08 14:19 UTC by Kaleb KEITHLEY
Modified: 2015-12-01 16:45 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1241133
Environment:
Last Closed: 2015-07-30 09:48:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-08 14:26:04 UTC
REVIEW: http://review.gluster.org/11582 (common-ha: ganesha-ha.sh status tries to read ganesha-ha.conf) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Anand Avati 2015-07-09 15:17:11 UTC
COMMIT: http://review.gluster.org/11582 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit be76b0e0b1e58538077daaf444d4f82123823213
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Jul 8 10:23:50 2015 -0400

    common-ha: ganesha-ha.sh status tries to read ganesha-ha.conf
    
    status doesn't need to read the config
    
    backport of
    > Change-Id: Id02252abe52820dbc263f4a880bde72a23b121bd
    > BUG: 1241133
    > http://review.gluster.org/#/c/11581/
    
    Change-Id: I036fd3072f38958373b1a85b0dc5c97245a72af4
    BUG: 1241134
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11582
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2015-07-30 09:48:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.