Bug 124128 - cryptoloop not working,
Summary: cryptoloop not working,
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 120660 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-24 11:16 UTC by Frank Büttner
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 22:22:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Büttner 2004-05-24 11:16:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.6)
Gecko/20040113

Description of problem:
When i try to use the cryptoloop module i get the error invalite argument.

Version-Release number of selected component (if applicable):
util-linux-2.12-18

How reproducible:
Always

Steps to Reproduce:
0. dd if=/dev/zero of=/tmp/test.dat count=10k
1. modprobe cryptoloop
2. modprobe aes
3. losetup -e aes-256 /dev/loop0 /tmp/test.dat
    

Actual Results:  after enter the password i get the error:
ioctl: LOOP_SET_STATUS: ivalit argument

Expected Results:  a working loop device

Additional info:

Comment 1 Elliot Lee 2004-05-24 19:01:30 UTC
*** Bug 120660 has been marked as a duplicate of this bug. ***

Comment 2 Elliot Lee 2004-05-26 22:22:42 UTC
Based on what I can gather, cryptoloop is deprecated in the 2.6
kernel, and the new interface (dm-crypt) is not yet fully supported in
userland. dm-crypt is on the TODO list though!

Comment 3 Ian Collier 2004-06-10 12:54:29 UTC
Why is this bug a WONTFIX?  All it requires is the correct patches for
the 2.6 kernel, documented here:
http://www.linux.org/docs/ldp/howto/Cryptoloop-HOWTO/userspace-tools.html

Sure it's deprecated, but it still works, and
 (a) until the userland dm-crypt tools are supplied with Fedora this
is the simplest way to get a crypto filesystem, and
 (b) the FC2 version of losetup is for the 2.4 kernel - it would seem 
stupid not to patch it to be compatible with the 2.6 kernel which comes
with FC2.


Note You need to log in before you can comment on or make changes to this bug.