Bug 1241458 - texlive-pgf has a broken pgfsys-tex4ht.def
Summary: texlive-pgf has a broken pgfsys-tex4ht.def
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1180868 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 09:24 UTC by Michael S. Tsirkin
Modified: 2015-12-12 01:53 UTC (History)
2 users (show)

Fixed In Version: texlive-2014-13.20140525_r34255.fc23 texlive-2014-10.20140525_r34255.fc22 texlive-2014-15.20140525_r34255.fc23 texlive-2014-12.20140525_r34255.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 20:27:54 UTC


Attachments (Terms of Use)

Description Michael S. Tsirkin 2015-07-09 09:24:31 UTC
Description of problem:
using htlatex produces an error in 
! Undefined control sequence.
\pgfsys@svg@newline ->\Hnewline 

Version-Release number of selected component (if applicable):
texlive-pgf-svn33057.3.0.0-8.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. see http://tex.stackexchange.com/questions/185349/error-using-pgfsysdriver-with-tex4ht-only-shows-up-with-texlive-2014-ok-with-t for a simple reproducer


Actual results:
file
/usr/share/texlive/texmf-dist/tex/generic/pgf/systemlayer/pgfsys-tex4ht.def
has this line:
\def\pgfsys@svg@newline{\Hnewline}
which breaks htlatex

this is a known bug.

Expected results:
replacing this line with def\pgfsys@svg@newline{^^J}
as suggested by that link fixes the issue for me.

Additional info:

Comment 1 Fedora Admin XMLRPC Client 2015-08-11 05:32:59 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Tom "spot" Callaway 2015-09-17 19:33:29 UTC
*** Bug 1180868 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2015-09-25 16:32:45 UTC
texlive-2014-13.20140525_r34255.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16620

Comment 4 Fedora Update System 2015-09-27 00:38:33 UTC
texlive-2014-10.20140525_r34255.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16621

Comment 5 Fedora Update System 2015-10-01 16:03:00 UTC
texlive-2014-13.20140525_r34255.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Michael S. Tsirkin 2015-10-01 16:21:23 UTC
This fixed the issue for me.
Thanks a lot!

Comment 7 Fedora Update System 2015-10-03 21:13:12 UTC
texlive-2014-10.20140525_r34255.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Michael S. Tsirkin 2015-10-21 14:50:31 UTC
Looks like the F22 package is broken in some way.

With texlive-2014-10.20140525_r34255.fc22 
/usr/share/texlive/texmf-dist/tex/generic/pgf/systemlayer/pgfsys-tex4ht.def
has \def\pgfsys@svg@newline{\Hnewline}
so of course it's broken again.

Re-opening.

Comment 9 Michael S. Tsirkin 2015-11-25 14:18:34 UTC
update: this is still with us on Fedora 23

texlive-2014-14.20140525_r34255.fc23.i686

Comment 10 Tom "spot" Callaway 2015-12-01 18:20:37 UTC
Sorry. My regex wasn't working. I've fixed it and rebuilt.

Comment 11 Fedora Update System 2015-12-01 18:21:46 UTC
texlive-2014-15.20140525_r34255.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cb744e62be

Comment 12 Fedora Update System 2015-12-01 18:21:47 UTC
texlive-2014-12.20140525_r34255.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c4745fe93d

Comment 13 Fedora Update System 2015-12-03 16:02:39 UTC
texlive-2014-12.20140525_r34255.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c4745fe93d

Comment 14 Fedora Update System 2015-12-04 01:38:03 UTC
texlive-2014-15.20140525_r34255.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cb744e62be

Comment 15 Fedora Update System 2015-12-07 20:27:51 UTC
texlive-2014-15.20140525_r34255.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-12-12 01:53:56 UTC
texlive-2014-12.20140525_r34255.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.