Bug 124211 - On user creation, target home directory need to be chown'ed
On user creation, target home directory need to be chown'ed
Status: CLOSED DUPLICATE of bug 99562
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 14:57 EDT by Ricky Ng-Adam
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Ng-Adam 2004-05-24 14:57:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After firstboot configuration and creation of a user, I tried logging
in but my desktop refused to come up.  I was pleasantly surprised that
this problematic situation was detected and that I was offered a
chance to have a look inside the .xsession-errors. The problem itself
was rather simple: since I had kept my old Mandrake /home partition
and the same username, the user and group ownership information was
incorrect.  

I feel this could have been detected by the firstboot program and the
permissions correctly changed.  To solve this, I instead had to switch
to the console and chown my home directory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Keep old /home partition from previous install with user 'x'
2. Create user 'x' at firstboot
3. Try to login
    

Actual Results:  Unable to login

Expected Results:  /home/x should have been chown'ed to proper permissions

Additional info:
Comment 1 Brent Fox 2004-05-25 11:48:14 EDT

*** This bug has been marked as a duplicate of 99562 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.