Bug 99562 - Installer does not correctly change ownership of files in /home
Summary: Installer does not correctly change ownership of files in /home
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: firstboot   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 124211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-21 20:58 UTC by Michael McCabe
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 21:10:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael McCabe 2003-07-21 20:58:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After I installed the beta ownership on all of the files for the users that
existed in previous Redhat Installation had to be changed unlike previous
versions. I reinstalled on a 2nd machine and the same error occured. The first
machine was running Debian and the 2nd machine was running redhat 9.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Do a fresh installation and add the same users that are in /home
2.
3.
    

Actual Results:  Received an error message that I couldn't write to the .gconf
directory

Expected Results:  The ownership on the files should have been changed

Additional info:

Comment 1 Brent Fox 2003-07-22 20:58:20 UTC
I'm trying to understand...you did a new install on a system that already had a
version of Linux on it.  You had a /home partition that you did not reformat,
and you created a user in firstboot who already had a home directory in /home. 
Is that right?

Comment 2 Michael McCabe 2003-07-23 00:23:25 UTC
Yes when I created the user in firstboot it did not change the ownership of  the
user's home directory.  

Comment 3 Brent Fox 2003-07-23 19:53:36 UTC
Did you not add the users back in the same order that they were originally
created in?

Comment 4 Brent Fox 2003-09-10 21:10:06 UTC
Closing as 'notabug'.  I don't think that either firstboot or the installer
should ever be changing ownership of files.

Comment 5 Brent Fox 2004-05-25 15:48:16 UTC
*** Bug 124211 has been marked as a duplicate of this bug. ***

Comment 6 Ricky Ng-Adam 2004-05-26 16:09:24 UTC
Why shouldn't firstboot change the ownership of files? This leads to
an error when the desktop environment comes up!!

Why not do this at firstboot, when a user is added:

1) check if ownership of /home/user is user:user
2) if not same, popup dialog:

"Your newly added user home directory already exist and has ownership
different then user:user.  This will prevent the desktop environment
from starting correctly.  Do you want to changes those permissions for
the directory and subdirectories? [Change] [Keep as same]"



Note You need to log in before you can comment on or make changes to this bug.