Bug 1242264 - Default configurations should support higher than 225 Content hosts
Summary: Default configurations should support higher than 225 Content hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-07-12 16:09 UTC by Mike McCune
Modified: 2019-04-01 20:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:24:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1244112 None None None Never

Internal Links: 1244112

Description Mike McCune 2015-07-12 16:09:51 UTC
If users deploy different #s of connected Content Hosts they have to reconfigure various settings for qpid to allow more than 225 and up:

https://access.redhat.com/solutions/1375253

We should reconfigure some of the values mentioned in that KCS during our installer puppet run to default to supporting at least 10K Content Hosts and possibly more.

Comment 4 Ivan Necas 2015-09-03 12:56:23 UTC
What's expected behavior here? Something like: `--capsule-expected-hosts-count`?

Comment 6 David O'Brien 2016-04-18 00:48:18 UTC
Reset docs contact <> daobrien

Comment 8 Roman Plevka 2016-07-12 13:03:15 UTC
VERIFIED

on sat6.2.0 snap19.1

I've set up a centos7 docker image with pre-installed subscription-manager and katello-consumer certificate from my satellite server.

I then ran many containers in a loop.

After triggering some batch package installation from WebUI, the number of qpid queues started to grow. I ended at 570 as that was as much containers i was able to start (didn't try to go further)
Seems like this amount of clients handled well

# qpid-stat -q --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 | grep -c pulp.agent
570

Comment 9 Bryan Kearney 2016-07-27 11:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.