This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 124235 - gnome-keyboard-properties generates popup error
gnome-keyboard-properties generates popup error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 17:39 EDT by Gergely Sztupkay
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 21:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gergely Sztupkay 2004-05-24 17:39:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
It is something like bug #120858... I've done every fix related that bug without success to solve this problem. 
This bug comes with Hungarian layouts only. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start gnome-keyboard-properties
2.choose layouts 
3.try to add any Hungarian layout
4.an error dialog appears with the error message in bug #120858

Actual Results:  An error dialog appears with the error message in bug #120858

Expected Results:  add the Hungarian to the active layouts 

Additional info:

I am after an upgrade from FC1 to FC2
Comment 1 Gabor Nagy 2004-05-30 05:23:42 EDT
Same here, but I had a clean FC2 install not an upgrade. Also tried
all from bug #120858.
The other layouts are Ok, but not the Hungarians.
Comment 2 Attila Balazs 2004-06-07 18:11:08 EDT
I had a clean install and also experinced the same. The only workout
were i i set up the hungarian layout as default. (Have you ever
attempted to operate a *nix computer with hu layout ? :)
Comment 3 Sergey V. Udaltsov 2004-06-07 18:57:48 EDT
IIRC Hungarian layout in XFree/XOrg was not combinable with others.
Sorry for that. (XKeyboardConfig fixed it). Did you try to use _only_
Hungarian?
Comment 4 Gabor Nagy 2004-06-08 02:13:19 EDT
Same problem...
Some observations:
If I use Gnome via VNC, everything looks fine. However the right-click
popup menu on the applet is different, so does the coming up keyboard
properties, and the applet looks different: it shows the national
flags instead of simply the textual name of the country.

So I guess it is some path problem that the X that VNC uses handless
well. (Or the VNC startup sets the paths correctly?)
Comment 5 Sergey V. Udaltsov 2004-06-08 05:25:09 EDT
Hehe:) VNC does not have XKB extension. In this case gnome keyboard
indicator falls back to the old gkb-new code - which has completely
different UI etc etc. So everything is working as expected - new code
is working for XKB only. Patches to add support for xmodmap to
libxklavier are mostly welcome.
Comment 6 Gabor Nagy 2004-06-09 01:54:53 EDT
I do not know how much it helps, but with system-config-redhat I can
switch the default layout to Hungarian, and it works properly.

[root@home_desktop xkb]# system-config-keyboard
Loading /lib/kbd/keymaps/i386/qwerty/hu101.map.gz
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'hu_qwerty',
'-model', 'pc105', '-option', '']

For me it is a workaround now.
Comment 7 Sergey V. Udaltsov 2004-06-09 05:42:20 EDT
You can use Hungarian. But you cannot mix it with other layouts IIRC.
Comment 8 Matthias Clasen 2005-04-22 02:12:34 EDT
*** Bug 151737 has been marked as a duplicate of this bug. ***
Comment 9 Matthias Clasen 2006-08-28 21:53:00 EDT
According to comment #3, the switch to xkeyboard-config should have fixed the
problem of combining hungarian with other layouts.

Note You need to log in before you can comment on or make changes to this bug.