Bug 1242609 - replacing a offline brick fails with "replace-brick" command
Summary: replacing a offline brick fails with "replace-brick" command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On: 1242543
Blocks: 1242728
TreeView+ depends on / blocked
 
Reported: 2015-07-13 17:47 UTC by Anuradha
Modified: 2016-06-16 13:23 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1242543
: 1242728 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:23:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-13 18:18:12 UTC
REVIEW: http://review.gluster.org/11651 (glusterd: Fix failure in replace-brick when src-brick is offline) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 2 Nagaprasad Sathyanarayana 2015-10-25 15:06:46 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 3 Niels de Vos 2016-06-16 13:23:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.