Bug 1242728 - replacing a offline brick fails with "replace-brick" command
Summary: replacing a offline brick fails with "replace-brick" command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On: 1242543 1242609
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-14 04:17 UTC by Anuradha
Modified: 2016-09-20 02:00 UTC (History)
12 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1242609
Environment:
Last Closed: 2015-07-30 09:49:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anuradha 2015-07-14 07:06:54 UTC
patch posted for review :
http://review.gluster.org/#/c/11656/

Comment 2 Anand Avati 2015-07-14 18:39:59 UTC
COMMIT: http://review.gluster.org/11656 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 1059bb42a8ef513484c12a33cef432e2156ae2dd
Author: Anuradha Talur <atalur@redhat.com>
Date:   Mon Jul 13 23:34:17 2015 +0530

    glusterd: Fix failure in replace-brick when src-brick is offline
    
    Change-Id: I0fdb58e15da15c40c3fc9767f2fe4df0ea9d2350
    BUG: 1242728
    Reviewed-on: http://review.gluster.org/11651
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Signed-off-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/11656

Comment 3 Kaushal 2015-07-30 09:49:14 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.