Bug 124265 - oowriter shows UTF-8 codes when entering international characters
oowriter shows UTF-8 codes when entering international characters
Status: CLOSED DUPLICATE of bug 124538
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 06:28 EDT by Peter Andreasen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 11:17:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Andreasen 2004-05-25 06:28:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; 
T312461)

Description of problem:
Installation of Fedora Core 2 is "Full". Default system language is 
set to British English. One user account is set up and at first login 
language preference is set to Danish. In all other programs the 
international characters and the keyboard layout work fine. But in 
the openoffice programs when entering æøå on the keyboard, æøå is 
what shows up on the screen.

Version-Release number of selected component (if applicable):
openoffice-1.1.1

How reproducible:
Always

Steps to Reproduce:
1. Select language "Danish" at login
2. In oowriter, try to enter æøå


Actual Results:  Screen shows æøå 

Expected Results:  The screen should show æøå

Additional info:

It is possible to insert the characters via the "insert special char" 
menu option.
Comment 1 Espen Vorland 2004-05-27 03:38:02 EDT
I have the same problem.

However, this is resolved if the iiimf service is stopped using the
command "service iiimf stop". Is this an iiimf bug or an OOo bug?
Comment 2 Peter Andreasen 2004-05-27 04:29:30 EDT
Additional comment: If oowriter is started from the command line I 
can change the value of LANG and the following happens:

[kevin@localhost kevin]$ export LANG=da_DK.utf-8
[kevin@localhost kevin]$ oowriter
I18N: X Window System doesn't support locale "da_DK.utf-8"
(here I can not even enter æøå, those keys are dead)

[kevin@localhost kevin]$ export LANG=da_DK.UTF-8
[kevin@localhost kevin]$ oowriter
(no warning but when I enter æøå I just get the same gibberish as 
described before)

[kevin@localhost kevin]$ export LANG=da_DK.iso8859-15
[kevin@localhost kevin]$ oowriter
I18N: X Window System doesn't support locale "da_DK.iso8859-15"
(Now æøå work in oowriter despite the warning from X)
Comment 3 Dan Williams 2004-06-10 08:58:16 EDT
Please test with OOo 1.1.1-6 that's now available in Rawhide.
Comment 4 Dan Williams 2004-06-10 08:58:34 EDT

*** This bug has been marked as a duplicate of 124538 ***
Comment 5 Caolan McNamara 2004-11-08 11:17:29 EST
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.