Bug 124538 - OpenOffice.org does not work properly with a Norwegian keyboard
OpenOffice.org does not work properly with a Norwegian keyboard
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: i18n
: 123388 124265 (view as bug list)
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-05-27 07:22 EDT by Singularity
Modified: 2008-04-08 08:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 09:20:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for fixing this problem (2.49 KB, patch)
2004-07-14 00:21 EDT, Leon Ho
no flags Details | Diff

  None (edit)
Description Singularity 2004-05-27 07:22:53 EDT
Description of problem:
OpenOffice.org does not work properly with a Norwegian keyboard.

Version-Release number of selected component (if applicable):
1.1.1-4 and 1.1.1-5

How reproducible:
Always.

Steps to Reproduce:
1. Make sure you have a Norwegian keyboard and that you have set up
the system to use the keyboard properly.
2. Open oowriter or oocalc
3. Hit the æ, ø and å keys (also with shift: Æ, Ø and Å).
  
Actual results:
Instead of æ, i get: æ
Instead of Æ, i get: Æ
Instead of ø, i get: ø
Instead of Ø, i get: Ø
Instead of å, i get: Ã¥
Instead of A, i get: Ã…

Expected results:
I should have gotten the letters displayed correctly in the text.

Additional info:
I have tested the keyboard layout (for instance I get '/' with
shift+7, so OpenOffice.org is not working with a US keyboard setup
internally). The Shell and all other programs that I have tested works
with these letters.
Comment 1 goahead 2004-05-27 11:33:32 EDT
The same here, with a swiss german keyboard. No problem in shell, but
in OpenOffice.org I get:

ö -> ö
é -> é
ä -> ä
à -> Ã 
ü -> ü
è -> è



Comment 2 MephistoUT 2004-05-31 07:57:43 EDT
Same here. Additional comments: I've checked out if the problem occurs
only in OpenOffice or also in other applications. From my point of
view, it is an OpenOffice problem. Other applications like gedit
(GNOME), Abiword or Gnumeric work fine.

The problem occurs after installing Fedora Core 2 on a new parition.
To make sure that no older setting plays it games, the dot-directories
were moved away for a test - the result was the same.
Comment 3 Marek Stanczyk 2004-05-31 17:10:06 EDT
Same thing for Slovak and Polish. I have two machines with FC2, one is
working correctly, the other one not. The one with more packages
installed (including Japanese support) is the one that doesn't work
(for SVK and PL, haven't figure out how to use Japanese yet :-)), if
that may be of any help.
Comment 4 Pedritor 2004-06-01 03:38:29 EDT
In 3 installs the only that has wrong keyboard is a complete install
(all packages).

Other people reported the same thing with full installs.

I'm using Spanish Language and all other apps works fine with local chars.
Comment 5 skuard 2004-06-03 06:55:24 EDT
Same here with a German keyboard. I can confirm that this only 
happens with fresh full-installs of FC2. If you do an update from FC1 
(full-install) to FC2 OpenOffice works fine. So the problems have to 
be in the packages that were added in FC2.
Comment 6 Marek Stanczyk 2004-06-03 07:16:37 EDT
Read some forums recently and it looks it's connected with the Asian
stuff. Somebody wrote that when he uninstalled Japanese/Chinese/...
support (didn't mention which packages exactly), the problem was gone.
Comment 7 goahead 2004-06-04 00:11:21 EDT
Stopping the Unicode Freewn, Canna and IIim (htt daemon) services
solved the problem for me. It is a shame that this issue, that
rendered the main office application of Fedora for all non english
speaking users useless didn't deserve one single comment by the Redhat
people. I'm quite disappointed.
Comment 8 MephistoUT 2004-06-04 05:09:13 EDT
100 points to 'goahead'.

Shutting down these three daemons solved the problem here, too. I
write this just to give a sign that it seems to be a "global solution".
Comment 9 Singularity 2004-06-04 07:51:06 EDT
The æ, ø and å keys works for me after stopping those services.

I had to shut them down, exit OO.o and then restart it in order for it
to work, though.

But this is really just a workaround. I hope that somebody will
provide a bugfix.
Comment 10 Dan Williams 2004-06-04 09:20:53 EDT
The reason there are no comments yet is that this seems to have been a
problem before...  there are bugs in bugzilla about using
Danish-specific symbols that don't work, and for others.  But this is
a problem that needs to get fixed, yes.  And help from the community
is important because otherwise it would take me twice as long as all
of you to track it down.  Now that there's a workaround, I can jump
into the code in vcl/unx/source/app/i18n_*.cxx and find out why X11 or
the input methods are not passing unicode into OOo, if that's the case.
Comment 11 Dan Williams 2004-06-08 10:16:10 EDT
I am not able to reproduce this bug.  Procedure:

1) run /usr/sbin/cannaserver
2) gkb_xmmap no
3) run OOo
4) type ø

or

1) run /usr/X11R6/bin/kinput2 -canna
2) gkb_xmmap no
3) run OOo
4) type ø

or

1) run /usr/bin/httx
2) gkb_xmmap no
3) run OOo
4) type ø

Could somebody enlighten me as to how the input servers that you
guys/girls run are launched?  Do you rely on the startup item scripts
for these, ie /etc/init.d/canna?
Comment 12 Dan Williams 2004-06-08 10:31:31 EDT
Hmm, am now able to reproduce with FreeWnn and Norwegian layout.
Comment 13 Dan Williams 2004-06-09 10:24:07 EDT
A workaround for this is to set your XMODIFIERS environment variable
to "@im=none" before starting OpenOffice.  This could be added to the
/usr/bin/ooffice script.  I'm looking into the actual problem with the
IIIMF guys.
Comment 14 Leon Ho 2004-06-10 01:21:27 EDT
*** Bug 123388 has been marked as a duplicate of this bug. ***
Comment 15 Dan Williams 2004-06-10 08:56:45 EDT
Please test with OOo 1.1.1-6 that's now available in Rawhide.
Comment 16 Dan Williams 2004-06-10 08:58:35 EDT
*** Bug 124265 has been marked as a duplicate of this bug. ***
Comment 17 Jan Eri 2004-06-19 06:46:45 EDT
I updated to openoffice.org 1.1.1-6.i386, and the problem was resolved
on my system. Norwegian characters display as expected now.
Comment 18 Dan Williams 2004-06-21 09:27:54 EDT
closing
Comment 19 Leon Ho 2004-07-14 00:20:54 EDT
Dan, thanks to the guys from Openi18n - I got a patch which fix the
double conversion problem. Can you give it a look please? If it is
okay then we can disable the enviornment variable workaround. 
Comment 20 Leon Ho 2004-07-14 00:21:33 EDT
Created attachment 101889 [details]
patch for fixing this problem
Comment 21 Dan Williams 2004-07-20 16:21:30 EDT
Verified that patch fixes the problem, will be in 1.1.2-1
Comment 22 Jan Eri 2004-08-21 11:02:21 EDT
This problem seems to be back with the 1.1.2 I downloaded just now. My
Norwegian characters again looks just like the original report here.
Comment 23 Jan Eri 2004-08-21 11:05:45 EDT
The version number for todays download seems to have been 1.1.2-3.i386
Comment 24 Jens Ziemann 2005-04-17 19:37:24 EDT
Hi there,

Error still not fixed. I´m running OOo 
openoffice.org-1.1.3-11.5.0
on a fully up2date FC3

Note You need to log in before you can comment on or make changes to this bug.