Bug 1242742 - Gluster peer probe with negative num
Summary: Gluster peer probe with negative num
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Mohamed Ashiq
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1247910
TreeView+ depends on / blocked
 
Reported: 2015-07-14 06:11 UTC by Mohamed Ashiq
Modified: 2016-06-16 13:23 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1065613
: 1247910 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:23:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohamed Ashiq 2015-07-14 06:11:21 UTC
+++ This bug was initially created as a clone of Bug #1065613 +++

Description of problem:
The gluster peer probe command with invalid ips dont report that IP's can also be a valid in usage.



[root@desktop8 /]# gluster peer status
Number of Peers: 0
[root@desktop8 /]# ifconfig -a
bash: ifconfig: command not found
[root@desktop8 /]# ifconfig
bash: ifconfig: command not found
[root@desktop8 /]# gluster peer status
Number of Peers: 0
[root@desktop8 /]# gluster peer probe server1
peer probe: failed: Probe returned with unknown errno 107
[root@desktop8 /]# gluster peer probe server223433
peer probe: failed: Probe returned with unknown errno 107
[root@desktop8 /]# gluster peer probe -1
-1 is an invalid address
Usage: peer probe <HOSTNAME> ----
[root@desktop8 /]


Version-Release number of selected component (if applicable):
[root@desktop8 /]# rpm -qa | grep glusterfs
glusterfs-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-cli-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-libs-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-server-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-fuse-3.5.0-0.5.beta3.fc20.x86_64
[root@desktop8 /]# 

How reproducible:


Steps to Reproduce:
1. Install glusterfs of above version 
2. Create bricks with XFS parttions and mount it
3. Issue gluster peer probe command with negative value

Actual results:
Usage: peer probe <HOSTNAME> 


Expected results:
Usage: peer probe <HOSTNAME>/IP address


Additional info:

Comment 1 Anand Avati 2015-07-14 08:23:39 UTC
REVIEW: http://review.gluster.org/11657 (Gluster peer probe with negative num) posted (#1) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

Comment 2 Anand Avati 2015-07-14 09:12:25 UTC
REVIEW: http://review.gluster.org/11657 (cli : changing the gluster peer probe message) posted (#2) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

Comment 3 Anand Avati 2015-07-14 09:25:26 UTC
REVIEW: http://review.gluster.org/11657 (cli : changing the gluster peer probe message) posted (#3) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

Comment 4 Anand Avati 2015-07-14 10:58:31 UTC
REVIEW: http://review.gluster.org/11657 (cli : changing the gluster peer probe message) posted (#4) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

Comment 5 Anand Avati 2015-07-28 08:41:30 UTC
COMMIT: http://review.gluster.org/11657 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 746f23ce055f7beed20aa4038f61ad5bdd84419f
Author: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
Date:   Tue Jul 14 12:24:21 2015 +0530

    cli : changing the gluster peer probe message
    
    The gluster peer probe command with invalid ips dont report that
    IP's can also be a valid in usage.
    
    Change-Id: I8f58341a2b76369ccf62f88ca0ecd8a9a9529af6
    BUG: 1242742
    Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/11657
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 6 Anand Avati 2015-07-29 08:04:42 UTC
REVIEW: http://review.gluster.org/11786 (cli : changing the gluster peer probe message) posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 14:52:59 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 13:23:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.