This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247910 - Gluster peer probe with negative num
Gluster peer probe with negative num
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Mohamed Ashiq
:
Depends On: 1242742
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 04:33 EDT by Mohamed Ashiq
Modified: 2015-09-09 05:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242742
Environment:
Last Closed: 2015-09-09 05:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-07-29 04:33:08 EDT
+++ This bug was initially created as a clone of Bug #1242742 +++

+++ This bug was initially created as a clone of Bug #1065613 +++

Description of problem:
The gluster peer probe command with invalid ips dont report that IP's can also be a valid in usage.



[root@desktop8 /]# gluster peer status
Number of Peers: 0
[root@desktop8 /]# ifconfig -a
bash: ifconfig: command not found
[root@desktop8 /]# ifconfig
bash: ifconfig: command not found
[root@desktop8 /]# gluster peer status
Number of Peers: 0
[root@desktop8 /]# gluster peer probe server1
peer probe: failed: Probe returned with unknown errno 107
[root@desktop8 /]# gluster peer probe server223433
peer probe: failed: Probe returned with unknown errno 107
[root@desktop8 /]# gluster peer probe -1
-1 is an invalid address
Usage: peer probe <HOSTNAME> ----
[root@desktop8 /]


Version-Release number of selected component (if applicable):
[root@desktop8 /]# rpm -qa | grep glusterfs
glusterfs-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-cli-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-libs-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-server-3.5.0-0.5.beta3.fc20.x86_64
glusterfs-fuse-3.5.0-0.5.beta3.fc20.x86_64
[root@desktop8 /]# 

How reproducible:


Steps to Reproduce:
1. Install glusterfs of above version 
2. Create bricks with XFS parttions and mount it
3. Issue gluster peer probe command with negative value

Actual results:
Usage: peer probe <HOSTNAME> 


Expected results:
Usage: peer probe <HOSTNAME>/IP address


Additional info:

--- Additional comment from Anand Avati on 2015-07-14 04:23:39 EDT ---

REVIEW: http://review.gluster.org/11657 (Gluster peer probe with negative num) posted (#1) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-14 05:12:25 EDT ---

REVIEW: http://review.gluster.org/11657 (cli : changing the gluster peer probe message) posted (#2) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-14 05:25:26 EDT ---

REVIEW: http://review.gluster.org/11657 (cli : changing the gluster peer probe message) posted (#3) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-14 06:58:31 EDT ---

REVIEW: http://review.gluster.org/11657 (cli : changing the gluster peer probe message) posted (#4) for review on master by Mohamed Ashiq (ashiq333@gmail.com)

--- Additional comment from Anand Avati on 2015-07-28 04:41:30 EDT ---

COMMIT: http://review.gluster.org/11657 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 746f23ce055f7beed20aa4038f61ad5bdd84419f
Author: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
Date:   Tue Jul 14 12:24:21 2015 +0530

    cli : changing the gluster peer probe message
    
    The gluster peer probe command with invalid ips dont report that
    IP's can also be a valid in usage.
    
    Change-Id: I8f58341a2b76369ccf62f88ca0ecd8a9a9529af6
    BUG: 1242742
    Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/11657
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

--- Additional comment from Anand Avati on 2015-07-29 04:04:42 EDT ---

REVIEW: http://review.gluster.org/11786 (cli : changing the gluster peer probe message) posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 1 Anand Avati 2015-07-29 04:33:59 EDT
REVIEW: http://review.gluster.org/11786 (cli : changing the gluster peer probe message) posted (#2) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Anand Avati 2015-07-29 04:35:19 EDT
REVIEW: http://review.gluster.org/11786 (cli : changing the gluster peer probe message) posted (#3) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 3 Anand Avati 2015-08-06 02:31:34 EDT
COMMIT: http://review.gluster.org/11786 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 14515d103d1f7636c0af87c19202c48d4d6813f4
Author: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
Date:   Tue Jul 14 12:24:21 2015 +0530

    cli : changing the gluster peer probe message
    
    The gluster peer probe command with invalid ips dont report that
    IP's can also be a valid in usage.
    
    	Backport of http://review.gluster.org/11657
    
    Cherry picked from 746f23ce055f7beed20aa4038f61ad5bdd84419f
    >Change-Id: I8f58341a2b76369ccf62f88ca0ecd8a9a9529af6
    >BUG: 1242742
    >Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
    >Reviewed-on: http://review.gluster.org/11657
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    
    Change-Id: I8f58341a2b76369ccf62f88ca0ecd8a9a9529af6
    BUG: 1247910
    Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
    Reviewed-on: http://review.gluster.org/11786
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Kaushal 2015-09-09 05:38:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.