Bug 1242903 - [RFE] [Neutron] [OSP-director] SR-IOV deployment support
Summary: [RFE] [Neutron] [OSP-director] SR-IOV deployment support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: beta
: 10.0 (Newton)
Assignee: Vijay Chundury
QA Contact: Yariv
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_newton-rc1 upstrea...
: 1258844 (view as bug list)
Depends On: 1371856 1383397
Blocks: 1188000 1368482 1334442 1335593
TreeView+ depends on / blocked
 
Reported: 2015-07-14 11:24 UTC by Joe Talerico
Modified: 2017-10-11 02:58 UTC (History)
25 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:13:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 313872 None None None 2016-05-17 13:27:30 UTC
Red Hat Bugzilla 1258844 None CLOSED [RFE] Add support for Neutron SR-IOV driver 2019-09-06 12:48:06 UTC

Internal Links: 1258844

Description Joe Talerico 2015-07-14 11:24:40 UTC
While this doesn't have to be across the board, it would be nice if the user could choose a "Network Performance" profile, which this would be the default, and they choose the PCI Device(s) on each of the hosts with the "Network Performance" Profile.

Have the installer do the following for Network Performance Profile:
Enable iommu in grub line
Probe PCI devices
Give the user the ability to choose PCI devices (YAML?) to enable SRIOV. In the YAML have the user specify # of VFs.
Set max_vfs= for the driver.
Setup the Nova PCI White-list : use devname?

Intentionally leaving out the Neutron setup, as DanS has a lot of that figured out.

Comment 3 Jeremy Eder 2015-08-03 12:18:18 UTC
We added some capabilities to tuned that might work for c#0.

We wrote NFV tuned profiles for RHEL7.2 and KVM, which is being woven into an NFV SKU.  I assume this is OSP-based but not sure (will find out).

Tuned in RHEL7.2 added support for a variables.conf file.  "Something", whether it's the user or OSP-installer, could write the PCI address of the device to this variables.conf.  Then, we could adjust the tuned profiles to implement whatever tuning you want (i.e. add VFs in sysfs).

Does this sound like it could work ?

Tuned doesn't handle module options yet, but here is an RFE for it:
https://bugzilla.redhat.com/show_bug.cgi?id=1249618

Comment 4 Jeremy Eder 2015-08-03 12:51:33 UTC
I should note that tuned already supports cmdline options, so we could use that to enable the IOMMU as well.

[bootloader]
cmdline = intel_iommu=on

Comment 5 Bob Sibley 2015-08-04 14:05:06 UTC
power setting in the BIOS need to be set so RHEL can use tuned, each vendor will be different and power setting for different models cold also be different:

DELL POWEREDGE R620

System Profile Setting:
       System Profile:    Performance PerWatt (OS)

Comment 7 Mike Burns 2016-04-07 20:43:53 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 10 Franck Baudin 2016-05-06 12:28:31 UTC
*** Bug 1258844 has been marked as a duplicate of this bug. ***

Comment 13 Assaf Muller 2016-09-29 20:30:33 UTC
Does latest OSPd contain relevant bits? If so, we can flip the bug to MODIFIED and fill in the 'fixed in version' field.

Comment 14 Assaf Muller 2016-10-05 13:44:24 UTC
@Vijay, I flipped it to MODIFIED so that our Errata tooling will be able to pick it up and set it to ON_QA. That is our product flow.

Comment 15 Vijay Chundury 2016-10-05 14:01:14 UTC
@Assaf thanks!

Comment 20 errata-xmlrpc 2016-12-14 15:13:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.