Bug 1242943 - Having no applicable Errata does not hint to uncheck applicable
Summary: Having no applicable Errata does not hint to uncheck applicable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Brad Buckingham
Russell Dickenson
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1122832 sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-07-14 13:06 UTC by Peter Vreman
Modified: 2019-04-01 20:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:16:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 11330 None None None 2016-04-22 16:46:11 UTC

Description Peter Vreman 2015-07-14 13:06:41 UTC
Description of problem:
When there are no content hosts with applicable data the Errata page gives an incorrect error message

I have errata working:
- I have loaded all RedHat channels
- I can create product Content Views and also see with errata numbers.

But going to Errata, with the default Applicable box checked i get:
“There are no Errata in this organization. Create one or more Products with Errata to view Errata on this page.”

There is no Hint in the error to Uncheck the Box to see All errata


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Load RedHat channels
2. Click on Errata
3. Do NOT create any hosts

Actual results:
No errata found error.

Expected results:
Hint to uncheck Applicable


Additional info:

Comment 2 Walden Raines 2015-08-11 18:41:36 UTC
Created redmine issue http://projects.theforeman.org/issues/11330 from this bug

Comment 3 Bryan Kearney 2015-08-14 17:02:02 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11330 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|7e2c1530d7153deab7e996748a2ba9006ebb2b0e.

Comment 9 Brad Buckingham 2016-03-24 20:02:48 UTC
Setup:
- Satellite 6.2 Snap 5 builds
- sync'ed several RH repositories
- there are 0 content hosts with applicable errata

Scenario:
- visit 'Content -> Errata'
- observed the following:
  - [x] Applicable, [] Installable <- default filters

  - Observe the following error:
    "There are 4418 total Errata in this organization but none match the above filters."

Comment 12 errata-xmlrpc 2016-07-27 09:16:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.