Bug 124305 - Unsupported nfs mount option: noquota while mounting automount maps
Unsupported nfs mount option: noquota while mounting automount maps
Status: CLOSED DUPLICATE of bug 122448
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 11:21 EDT by Jim
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim 2004-05-25 11:21:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1

Description of problem:
Our site has many existing nis maps for autofs.  The autofs/kernel with
Fedora Core 1 used the existing maps with no difficulty.  With Fedora
Core 2, we have issues with mount options which used to be silently
ignored.  Specifically, we have maps with the quota, noquota, or grpid
mount options.  These do apply to the Irix, sunos, solaris, or unicos
systems we have and our IS is reluctant to remove those options.

I believe the source of the problem is the kernel NFS implementation
no longer silently ignores these options.  Is that correct?  If so,
can that be disabled?  Is there any way I can work around this with
any automount options that say ignore these options?  Can I kludge
around it with any sort of shell script that is used instead of ypcat
that sed's off the grpid, quota, or noquota options?

We have multiple levels of maps.  I did tweak the top level use of
ypcat to get rid of the quota, grpid, noquota options, but then
the second and other levels of mappings fail.  Any ideas?

Version-Release number of selected component (if applicable):
autofs-4.1.2.6    nfs-utils-1.0.6-20

How reproducible:
Always

Steps to Reproduce:
1.Try mounting an automount map with a "noquota" option mountded from
a Irix or solaris server
2.
3.
    

Actual Results:  The mountpoint fails to mount.  /var/log/messages
states:  Unsupported nfs mount option: noquota, quota or grpid options.

Expected Results:  NFS should properly ignore the uknown/invalid
(quota, noquota, etc..) mount options.

Additional info:
Comment 1 Jeffrey Moyer 2004-05-25 11:27:42 EDT
The ignoring of unknown options was removed with an nfs patch by
accident.  Please fix.

*** This bug has been marked as a duplicate of 122448 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.