Bug 122448 - autofs fails to mount with error "Unsupported nfs mount option: nobrowse"
autofs fails to mount with error "Unsupported nfs mount option: nobrowse"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
: 124305 124983 127178 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 13:14 EDT by Chris Lahti
Modified: 2007-11-30 17:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 11:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible patch (335 bytes, patch)
2004-05-28 10:11 EDT, Michael Young
no flags Details | Diff

  None (edit)
Description Chris Lahti 2004-05-04 13:14:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
automount via NIS starts as expected, however when attempting to go to
a mount point, the operation fails.

this is what I get when I type mount (seems to be ok):

[root@lnclahti root]# mount
/dev/hda2 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/hda1 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid6382) on /tools type autofs
(rw,fd=4,pgrp=6382,minproto=2,maxproto=4)
automount(pid6420) on /archive type autofs
(rw,fd=4,pgrp=6420,minproto=2,maxproto=4)
automount(pid6464) on /projects type autofs
(rw,fd=4,pgrp=6464,minproto=2,maxproto=4)
automount(pid6505) on /home type autofs
(rw,fd=4,pgrp=6505,minproto=2,maxproto=4)
automount(pid6546) on /proj_mm8 type autofs
(rw,fd=4,pgrp=6546,minproto=2,maxproto=4)
automount(pid6587) on /proj_arm333 type autofs
(rw,fd=4,pgrp=6587,minproto=2,maxproto=4)
automount(pid6666) on /proj_mm7 type autofs
(rw,fd=4,pgrp=6666,minproto=2,maxproto=4)
automount(pid6628) on /groups type autofs
(rw,fd=4,pgrp=6628,minproto=2,maxproto=4)

this is what I get when I try to go to a mounted directory:

[root@lnclahti root]# cd /tools/config
bash: cd: /tools/config: No such file or directory

This is what /var/log/messages has to say about it:

May  4 10:10:32 lnclahti automount[6678]: failed to mount /tools/config
May  4 10:13:18 lnclahti automount[6764]: >> Unsupported nfs mount
option: nobrowse
May  4 10:13:18 lnclahti automount[6764]: mount(nfs): nfs: mount
failure santaclara7:/export/sc7_1/tools/config/Linux on /tools/config
May  4 10:13:18 lnclahti automount[6764]: failed to mount /tools/config
May  4 10:13:18 lnclahti automount[6766]: >> Unsupported nfs mount
option: nobrowse
May  4 10:13:18 lnclahti automount[6766]: mount(nfs): nfs: mount
failure santaclara7:/export/sc7_1/tools/config/Linux on /tools/config
May  4 10:13:18 lnclahti automount[6766]: failed to mount /tools/config
May  4 10:13:18 lnclahti automount[6768]: >> Unsupported nfs mount
option: nobrowse
May  4 10:13:18 lnclahti automount[6768]: mount(nfs): nfs: mount
failure santaclara7:/export/sc7_1/tools/config/Linux on /tools/config
May  4 10:13:18 lnclahti automount[6768]: failed to mount /tools/config

This NIS setup has worked for several years with RH 7x all the way to
FC1 with no problems.  It does not matter if the NFS server is Linux,
Solaris or even NetApp, the problem is the same.

Version-Release number of selected component (if applicable):
autofs-4.1.2-2 ypbind-1.17.2-1 yp-tools-2.8-3

How reproducible:
Always

Steps to Reproduce:
1. boot system
2. log in as root (user account fails since /home automount not working
3. attempt to cd to automount point
    

Actual Results:  operation fails, and /var/log/messages logs error
message:
Unsupported nfs mount option: nobrowse

Expected Results:  automount works correctly

Additional info:
Comment 1 Jeffrey Moyer 2004-05-04 13:22:36 EDT
Can you manually mount that share with the nobrowse option?
Comment 2 Chris Lahti 2004-05-04 13:42:27 EDT
My current workaround for my home directory is to:

shutdown autofs
mkdir -p /home/clahti
mount 192.168.51.16:/export/sc5_2/home/clahti /home/clahti

that works.

mount -nobrowse santaclara7:/export/tools/config /mnt/test

results in "Unsupported nfs mount option: browse"

mount santaclara7:/export/tools/config /mnt/test

results in successful mount

We are not using the nobrowse option anywhere, either NFS server or
client that I can find.
Comment 3 Jeffrey Moyer 2004-05-04 13:45:56 EDT
could you post your auto.master, and the map file for /tools?

Thanks!
Comment 4 Chris Lahti 2004-05-04 13:52:46 EDT
here you go:

[clahti@lnclahti ~]$ cd /etc
[clahti@lnclahti /etc]$ cat auto.master
#
# $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc  /etc/auto.misc --timeout=60
#/misc  /etc/auto.misc
#/net   /etc/auto.net


[root@scadmin maps]# cat auto.tools
*     santaclara7:/export/sc7_1/tools/&/$OSNAME
Comment 5 Jeffrey Moyer 2004-05-04 13:55:38 EDT
There is no entry for auto.tools in there.  How about sending along
the results of:

ypcat auto.master

Thanks!
Comment 6 Chris Lahti 2004-05-04 14:02:21 EDT
Here you go:

[clahti@lnclahti /etc]$ ypcat auto.master
auto.tools       -nobrowse,timeo=120,int,retrans=6
auto.archive     -nobrowse,timeo=120,int,retrans=6
auto.projects    -nobrowse,timeo=120,int,retrans=6
auto.home        -nobrowse,timeo=120,int,retrans=6
auto.proj_mm8    -nobrowse,timeo=120,int,retrans=6
auto.proj_arm333 -nobrowse,timeo=120,int,retrans=6
auto.groups      -nobrowse,timeo=120,int,retrans=6
auto.proj_mm7    -nobrowse,timeo=120,int,retrans=6

doh! I see the -nobrowse option now, but apparently this works for all
RH up to FC1, as well as Solaris and HPUX.

A bit more clarification on the map syntax, the &/$OSNAME portion
allows us to  mount a tool with the identical client side path from
Linux, Solaris or HPUX, but have different physical binaries, for example

logical path
/tools/cadence/bin

physical path = 
Linux: santaclara7:/export/sc7_1/tools/cadence/Linux/bin
SunOS: santaclara7:/export/sc7_1/tools/cadence/SunOS/bin
HPUX: santaclara7:/export/sc7_1/tools/cadence/HPUX/bin

so I should say that

mount santaclara7:/export/tools/config/Linux /mnt/test

successfully mounts, but this should not pose a problem...
Comment 7 Jeffrey Moyer 2004-05-04 14:41:55 EDT
Ahh, I see.  nobrowse is a solaris automount option.  See below for
the excerpt from their man page.

I agree that this is a bug.  It looks like the older autofs passed the
-s option to mount (sloppy).  This allowed for mount to succeed even
if the options specified were not supported by the filesystem.

I'll work on fixing this in the newest autofs.

Thanks!

Jeff


====================================================================
Browsing
     The Solaris 2.6 release supports  browsability  of  indirect
     maps.  This  allows  all of the potential mount points to be
     visible, whether or not they  are  mounted.  The   -nobrowse
     option can be added to any indirect
      autofs map to disable browsing. For example:

     /net     -hosts      -nosuid,nobrowse
     /home    auto_home

     In this case, any hostnames would only be visible  in   /net
     after they are mounted, but all potential mount points would
     be  visible  under  /home.   The   -browse  option   enables

SunOS 5.9            Last change: 1 Nov 1999                    7

System Administration Commands                      automount(1M)

     browsability  of   autofs  file systems. This is the default
     for all indirect maps.
====================================================================
Comment 8 Jeffrey Moyer 2004-05-04 15:20:33 EDT
It turns out that we removed support for sloppy mounts for nfs in our
version of mount.  This is not desirable and should be fixed.

The upstream 2.12 sources still support sloppy in nfsmount.c.  The
patch which removes this is: util-linux-2.11z-01-nfs.patch.

The section of code we're interested in here is in mount/nfsmount.c:

    } else {
        if (!sloppy) {
            printf(_("unknown nfs mount option: "
                     "%s%s\n"), val ? "" : "no", opt);
            goto fail;
        }
    }
Comment 9 Jeffrey Moyer 2004-05-25 11:27:43 EDT
*** Bug 124305 has been marked as a duplicate of this bug. ***
Comment 10 Elliot Lee 2004-05-26 18:54:08 EDT
This was fixed in util-linux-2.12-18 (which got into FC2).
Comment 11 Michael Young 2004-05-28 08:32:28 EDT
Actually, I don't think it is fixed. We are still seeing this with
automounts with quota/noquota options for Solaris, with a fresh
install of FC2.
Note that the patch above refers to "unknown nfs mount option: "
whereas the error I get is "Unsupported nfs mount option:"
Comment 12 Jim 2004-05-28 09:48:29 EDT
I agree with Michael.  Something is still broke with FC2. With a stock
FC2 install we are seeing the  "Unsupported nfs mount option:"  for
the "quota/noquota/grpid, etc..." options on mounts generated from
Solaris & Irix systems.
Comment 13 Michael Young 2004-05-28 10:11:12 EDT
Created attachment 100665 [details]
possible patch

I think the problem is in the code added in the util-linux-2.11z-01-nfs.patch
patch to mount/nfsmount.c . In the parse_options subroutine, the code is just
dropping through to the bad_options: tag, and dropping out there. We probably
want something like this (at the moment untested) patch.
Comment 14 Jeffrey Moyer 2004-05-28 10:32:53 EDT
Ahh, indeed.  My fault for looking at the wrong case.  This patch
looks reasonable to me.  Thanks for taking the time to look into it!

-Jeff
Comment 15 Michael Young 2004-05-28 11:59:13 EDT
I have now built an rpm with my patch applied, and it seems to fix the
problem for me at least.
Comment 16 Jeffrey Moyer 2004-06-01 17:01:54 EDT
*** Bug 124983 has been marked as a duplicate of this bug. ***
Comment 17 Elliot Lee 2004-06-03 16:35:07 EDT
I'm going to incorporate this patch into the upcoming 2.12a-1 package.
Thanks!
Comment 18 Axel Thimm 2004-06-25 13:21:49 EDT
This big has been "closed rawhide", but the available util-linux
package is still the buggy one.

Could you make the resolution true? :)

Also, could you pick up the selinux patches in bug #126720?

Thanks!
Comment 19 Paul Waterman 2004-06-29 14:32:42 EDT
From what I can see, to get things working again, you need to grab two
parts:

(1) A fix to util-linux (grab util-linux-2.12a-2.i386.rpm from the
development area) is necessary to make the mount -s option work again.

(2) A fix to autofs (grab autofs-4.1.3-8.i386.rpm from the development
area) is also apparently necessary to make autofs use the -s option
again. (And of course, this requires numerous dependency updates -- bleh.)
Comment 20 Jeffrey Moyer 2004-06-29 14:40:08 EDT
All version of autofs use the -s option.  You only need (1) above.

-Jeff
Comment 21 Axel Thimm 2004-06-29 15:30:11 EDT
It would be nice to see both in errata to FC, but this is probably
below errata priority. You can use the fixed rpms from ATrpms, no
further dependencies than the two rpms:

http://ATrpms.net/name/autofs/
http://ATrpms.net/name/util-linux/

Tested with fc1.
Comment 22 Jeffrey Moyer 2004-07-06 06:36:58 EDT
*** Bug 127178 has been marked as a duplicate of this bug. ***
Comment 23 Michael Young 2004-10-05 07:26:18 EDT
This problem is back again in the current rawhide package (2.12a-10).
Comment 24 Michael Young 2004-10-05 11:39:18 EDT
The patch I suggested in #13 still fixes the problem for me when
applied to 2.12a-10.
Comment 25 Elliot Lee 2004-10-06 11:57:35 EDT
Looks like a hunk got dropped during a patch merge. SteveD is fixing.
Thanks for keeping us posted!
Comment 26 Matt Phelps 2004-10-13 11:44:24 EDT
This problem is critical for us! We can't upgrade dozens of machines.
Please make this an errata update.
Comment 27 Michael Young 2004-10-13 11:59:16 EDT
It was fixed in rawhide as of 2.12a-11 (and I verified the fix in that
version on an FC2 host).

Note You need to log in before you can comment on or make changes to this bug.