Bug 1243155 - hosted-engine fails to transfer the appliance image to the storage domain because the lv was not activated
Summary: hosted-engine fails to transfer the appliance image to the storage domain bec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.5.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks: 1247888
TreeView+ depends on / blocked
 
Reported: 2015-07-14 22:10 UTC by nijin ashok
Modified: 2019-07-11 09:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1247888 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:13:20 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1530223 None None None Never
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 41965 None None None Never

Description nijin ashok 2015-07-14 22:10:30 UTC
Description of problem:

When a hosted engine is deployed over iSCSI using rhevm appliances, then the installation fails with error

2015-07-10 16:54:03 DEBUG otopi.plugins.ovirt_hosted_engine_setup.vm.boot_disk plugin.execute:937 execute-output: ('/usr/bin/sudo', '-u', 'vdsm', '-g', 'kvm', '/usr/bin/qemu-img', 'convert', '-O', 'raw', '/tmp/tmpNz3CRC', '/rhev/data-center/mnt/blockSD/dce0eb3b-e8ed-4bf7-b61e-80addbac6bea/images/cf8d1a5e-d980-41d3-907b-b8b2d8ab342a/947162b4-9938-4a0b-8bcf-7b4ca427ab19') stderr:
/rhev/data-center/mnt/blockSD/dce0eb3b-e8ed-4bf7-b61e-80addbac6bea/images/cf8d1a5e-d980-41d3-907b-b8b2d8ab342a/947162b4-9938-4a0b-8bcf-7b4ca427ab19: error while converting raw: Permission denied

If we manually activate the lv just after the creation of VM Image then the installation works

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.4-2.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run hosted-engine --deploy
2. Select storage as "iscsi"
3. Select disk as "device to boot the VM from" and provide the path to rhevm appliance ova file

Actual results:

Installation failed at step

"Extracting disk image from OVF archive (could take a few minutes depending on archive size)"

Expected results:

Installation should complete successfully

Additional info:

Upstream bug : https://bugzilla.redhat.com/show_bug.cgi?id=1222058

Comment 1 Sandro Bonazzola 2015-07-17 12:45:32 UTC
Already on QA for 3.6

Comment 5 Elad 2015-08-13 07:56:31 UTC
The appliance image is transferred successfully using iSCSI storage. Hosted-engine deployment passes.

Used:
ovirt-3.6.0-5
ovirt-engine-appliance-20150802.0-1.el7.centos.noarch
ovirt-hosted-engine-setup-1.3.0-0.0.master.20150729070044.git26149d7.el7.noarch

Comment 7 errata-xmlrpc 2016-03-09 19:13:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.