Bug 124329 - (ACPI) kernel panic at start of installation process
(ACPI) kernel panic at start of installation process
Status: CLOSED DUPLICATE of bug 121760
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 13:54 EDT by Msquared
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff file beteen Fedora Core 2 kernel config and Debian 2.6.5 claimed to work (48.26 KB, text/plain)
2004-05-31 08:15 EDT, Patrick Pollet
no flags Details
the config file of Debian with 2.6.5 claimed to work (3.91 KB, text/plain)
2004-05-31 08:19 EDT, Patrick Pollet
no flags Details
Successful /var/log/messages (31.59 KB, text/plain)
2004-06-01 10:18 EDT, Patrick Pollet
no flags Details

  None (edit)
Description Msquared 2004-05-25 13:54:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
After selecting graphic or text install, the kernel is loaded and
decompressed.  As soon as the decompressed kernel is started, it
panics with the message "Attempted to kill init!".

I've tried to limit memory with mem=128M (my system has 512M), I've
tried noprobe, and the problem persists.

The system is a Gigabyte GA-7VRXP with DVD-ROM, CDRW-burner, 80GBhd,
512MB RAM, and an Athlon.

An older system I tried to install on (an old Pentium) also failed
this way.

Fedora Core 1 has successfully been installed on both platforms that
paniced while attempting to install Fedora Core 2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Turn on machine
2.  Insert FC2 disc 1
3.  Select graphic or text install
    

Actual Results:  Kernel panic.

Expected Results:  Installation to proceed normally.

Additional info:

EIP is at acpi_ps_parse_aml+0xb2/0x1a4
eax: 00000000  ebx: c147cc00  ecx: c02b38c9  edx: 00000d60
esi: c147cc00  edi: c147bf44  ebp: 00000007  esp: dffd5f60
ds: 007b  es: 007b  ss: 0068
Process swapper (pid: 1, threadinfo=dffd5000 task=dfd47630)
Stack: 00000000 00000000 c147cc00 dffe0284 00000001 c01aa473 dffe0144
dffe0144
       c037e634 00000000 c01aa492 dffe0144 c01a84bd dffe0144 00000000
00000000
       c01a852e 00000000 00000000 00000000 c01a85e2 c01ae62d 00000001
000fc0d0
Call Trace:
 [<c01aa473>] acpi_ns_one_complete_parse+0x6b/0x7b
 [<c01aa492>] acpi_ns_parse_table+0xf/0x29
 [<c01a84bd>] acpi_ns_load_table+0x6d/0x8f
 [<c01a852e>] acpi_ns_load_table_by_type+0x4f/0xea
 [<c01a85e2>] acpi_ns_load_namespace+0x19/0x34
 [<c01ae62d>] acpi_load_tables+0xd9/0x139
 [<c032ccc5>] acpi_bus_init+0x26/0x11b
 [<c032ce1c>] acpi_init+0x62/0xb4
 [<c0320659>] do_initcalls+0x49/0x97
 [<c010029e>] init+0x0/0xe2
 [<c01002bb>] init+0x1d/0xe2
 [<c01041d5>] kernel_thread_helper+0x5/0xb

Code: 82 78 10 00 75 0e 80 48 09 08 8b 83 ac 01 00 00 c6 40 1c 01
 <0>Kernel panic: Attempted to kill init!
Comment 1 Patrick Pollet 2004-05-31 08:15:39 EDT
Created attachment 100716 [details]
diff file beteen Fedora Core 2 kernel config and Debian 2.6.5 claimed to work
Comment 2 Patrick Pollet 2004-05-31 08:16:11 EDT
Hello,
   I got exactly the same error on an Asus M2400N laptop. 
   I succeeded booting and installing Fedora Core 2 by passing 
acpi=ht parameter to kernel.

   Unfortunately, since acpi is disabled, the sound card and pcmcia
does not work. 
Here is the relevant parts of /var/log/messages:

May 29 11:20:34 port107-pp kernel: Kernel command line: ro
root=LABEL=/ acpi=ht rhgb quiet
...
    May 29 11:20:36 port107-pp kernel: ACPI: Subsystem revision 20040326
May 29 11:20:36 port107-pp kernel: ACPI: Interpreter disabled.
May 29 11:20:36 port107-pp kernel: Linux Plug and Play Support v0.97
(c) Adam Belay
May 29 11:20:37 port107-pp kernel: usbcore: registered new driver usbfs
May 29 11:20:37 port107-pp kernel: usbcore: registered new driver hub
May 29 11:20:37 port107-pp kernel: ACPI: ACPI tables contain no PCI
IRQ routing entries
May 29 11:20:37 port107-pp kernel: PCI: Invalid ACPI-PCI IRQ routing table
May 29 11:20:37 port107-pp kernel: PCI: Probing PCI hardware
May 29 11:20:37 port107-pp kernel: PCI: Probing PCI hardware (bus 00)
May 29 11:20:37 port107-pp kernel: PCI: Ignoring BAR0-3 of IDE
controller 0000:00:1f.1
May 29 11:20:37 port107-pp kernel: Transparent bridge - 0000:00:1e.0
May 29 11:20:37 port107-pp kernel: PCI: Using IRQ router default
[8086/24cc] at 0000:00:1f.0
May 29 11:20:37 port107-pp kernel: PCI: IRQ 0 for device 0000:00:1f.1
doesn't match PIRQ mask - try pci=usepirqmask
May 29 11:20:37 port107-pp kernel: PCI: IRQ 0 for device 0000:00:1f.5
doesn't match PIRQ mask - try pci=usepirqmask
May 29 11:20:37 port107-pp kernel: PCI: IRQ 0 for device 0000:00:1f.6
doesn't match PIRQ mask - try pci=usepirqmask
May 29 11:20:37 port107-pp kernel: PCI: IRQ 0 for device 0000:01:03.0
doesn't match PIRQ mask - try pci=usepirqmask
May 29 11:20:37 port107-pp kernel: PCI: IRQ 0 for device 0000:01:03.1
doesn't match PIRQ mask - try pci=usepirqmask
 [snip]
May 29 11:20:38 port107-pp kernel: PCI: IRQ 0 for device 0000:00:1f.6
doesn't match PIRQ mask - try pci=usepirqmask
May 29 11:20:38 port107-pp kernel: PCI: No IRQ known for interrupt pin
B of device 0000:00:1f.6. Please try using pci=biosi
rq.
...

 I did try various combinations of kernel parameters with no success
(no sound) such as:
   nolapic 
   nolapic pci=noacpi
   nolapic pci=biosirq
   nolapic pci=usepirqmask  
  All of them gave me the kernel panic.
   
   I can use my Fedora only with acpi=ht ( or acpi=off) ...


  Please note that my colleague succeeded with a mandrake 10.0 (kernel
2.6.3) community by using nolapic pci=usepirqmask. He has sound !!!
And there are reports on Google of successful Debian install with
Kernel 2.6.5 on this laptop such as:
http://people.easter-eggs.org/~valos/Asus_M2400N/Asus_M2400N.html
http://www.bigendian.dk/ASUSM2400N.html

  Finally I should say that I succeeded to have sound with RedHat 9 on
this laptop by customizing/compiling a 2.4.22 kernel. But the harddisk
 was extremely slow (hdparm gaves 3Mb/s), that's why I tried Fedora
core 2... So far I am disappointed.

   There should be something missing or incorrect in the kernel's
config files for Fedora Core 2.. But what ?
  I am quite willing to help 


    
Comment 3 Patrick Pollet 2004-05-31 08:19:34 EDT
Created attachment 100717 [details]
the config file of Debian with 2.6.5 claimed to work 

Here is the config file of the debian distro claimed to work by 
http://people.easter-eggs.org/~valos/Asus_M2400N/Asus_M2400N.html
Comment 4 Steven Burke 2004-06-01 00:30:39 EDT
I have the same issue as Msquared.
I also get this with the FC2 recovery CD.

I am running dual XP and FC1.

My system :
 Intel Celeron 2.6ghz
 Maxtor 91366U4 (12Gb) IDE
 ST360015A        (60Gb) IDE
 NVIDIA FX5200
Comment 5 Msquared 2004-06-01 00:47:29 EDT
Workaround: adding the parameter "acpi=off" to the kernel while
installing allowed me to successfully install Fedora Core 2.  I also
had to add "acpi=off" to the kernel when booting in order to
successfully boot Fedora Core 2.  Thanks to Patrick for the hints.

Comment 6 Steven Burke 2004-06-01 06:35:30 EDT
I tried :
acpi=off
acpi=ht
pci=noacpi

still the same Kernel panic.

However,
my actual info is different to yours:

Process swapper (pid: 1, threadinfo=f7d90000 task=f7d49630)
Stack: 0000002b 00000000 c015a352 c02d4c80 00000000 0000002b c1997f84
c02d4c80
       c17fd9e0 c014f6d4 0000002b c016e2dc fffffff4 c199aa18 0000002c
c199a980
       c1997f84 c199b580 c1997fb0 00000000 c016e31d c199b580 c199b580
c1997f91
Call Trace:
 [<c015a352>] simple_prepare_write+0x31/0x94
 [<c014f6d4>] init_symlink+0x4e/0x10e
 [<c016e2dc>] init_symlink+0x0/0xd
 [<c016e31d>] sysfs_symlink+0x34/0x49
 [<c016e49a>] sysfs_create_link+0xed/0x117
 [<c01dbbc7>] bus_match+0x3f/0x45
 [<c01dcc7b>] driver_attach+0x37/0x6a
 [<c01dce8d>] bus_add_driver+0x6a/0x81
 [<c01dd173>] driver_register+0x28/0x2c
 [<c0199051>] pci_create_newid_file+0x15/0x1a
 [<c0199315>] pci_register_driver+0x4b/0x67
 [<c032f0fb>] agp_intel_init+0x20/0x27
 [<c0320659>] do_initcalls+0x49/0x97
 [<c010029e>] init+0x0/0xe2
 [<c01002bb>] init+0x1d/0xe2
 [<c01041d5>] kernel_thread_helper+0x5/0xb

Code: 0f 0b 2a 00 78 90 29 c0 2b 0d cc 90 37 c0 c1 f9 05 c1 e1 0c
 <0>Kernel panic: Attempted to kill init!
Comment 7 Patrick Pollet 2004-06-01 10:15:36 EDT
Hello again,   
   I solved it from infos in bug # 121760.   
   I applied the patch by luming (comment #18) to linux/drivers/acpi/dsopcode.c ( 3   
lines to comment out), and recompiled the kernel & modules...   
    Now my laptop boots with 2.6.5-1.358custom    
without any acpi=xx parameter AND acpi is enabled OK.   
No more kernel panic (execpt of course from FC2 CD1 or image on usb disk).   
   
The directory /proc/acpi is populated and my sound card Intel 82801DB    
WORKS :-))   
  Just have to modify kernel-ntfs and ipw2100 rpms to install in   
/lib/modules/2.6.5-1.358custom  instead of /lib/modules/2.6.5-1.358   
   
  This may not help Steven since he do not have the same error code .  
  
Thanks and cheers ;-)   
Comment 8 Patrick Pollet 2004-06-01 10:18:20 EDT
Created attachment 100737 [details]
Successful /var/log/messages

What I was expecting for a long time. Cheers to FC2 ;-)
Comment 9 Len Brown 2004-06-04 00:25:00 EDT
Thank-you Patrick for proving this is a duplicate of bug 121760. 
Steven has a different (non-ACPI) failure and should open a different bug. 
closing this bug as a duplicate of bug 121760... 

*** This bug has been marked as a duplicate of 121760 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:03:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.