Bug 121760 - (ACPI) acpi=off fixes, acpi boot crash on asus s1300n centrino
(ACPI) acpi=off fixes, acpi boot crash on asus s1300n centrino
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 121328 122577 123488 123528 124329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 11:48 EDT by Markus Bertheau
Modified: 2015-01-04 17:05 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 00:51:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of kernel crash (238.54 KB, image/jpeg)
2004-04-27 11:49 EDT, Markus Bertheau
no flags Details
dsdt for asus m3425ch (28.87 KB, application/octet-stream)
2004-05-19 10:12 EDT, paolo borelli
no flags Details
dsdt for an ASUS S5200N with the 210 bios update. (25.10 KB, application/octet-stream)
2004-05-19 22:26 EDT, Matthew Faull
no flags Details
patch for fixing this oops, against 2.6 (725 bytes, patch)
2004-05-20 07:14 EDT, Luming Yu
no flags Details | Diff

  None (edit)
Description Markus Bertheau 2004-04-27 11:48:34 EDT
Hi,

I run Fedora Core test 3 with the redhat kernel 2.6.5-1.332 on an Asus
S1300N contrino notebook and booting
without acpi=off will crash the kernel. I'll attach a photo of the
crash. That happens every time.

I need acpi because otherwise every other pci device gets assigned irq 5
and sound doesn't work.

[sweta@pupsik sweta]$ cat /proc/interrupts
           CPU0
  0:    4134806          XT-PIC  timer
  1:       2309          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  4:          0          XT-PIC  ehci_hcd
  5:     220415          XT-PIC  uhci_hcd, uhci_hcd, uhci_hcd, eth1
  8:          1          XT-PIC  rtc
 12:     573134          XT-PIC  i8042
 14:     112840          XT-PIC  ide0
NMI:          0
ERR:          0
Comment 1 Markus Bertheau 2004-04-27 11:49:37 EDT
Created attachment 99715 [details]
Photo of kernel crash
Comment 2 Sven Lundblad 2004-04-30 10:23:32 EDT
I have the same problem on an ASUS M3000N laptop.
Comment 3 Soren C. Sorensen 2004-05-02 17:46:20 EDT
I have almost completely similar output on an ASUS M3000N laptop with 
248MB RAM and a Pentium M 1700MHz CPU.

This occurs everytime I have attempted to install using a cd burned 
from the file FC2-test3-i386-disc1.iso and occurs after the initial 
screen after pressing enter 'to install or upgrade' or 
entering 'linux test'

Looking at the image, the only obvious difference is the line that 
begins "Code:". This is what I get:

Code: 89 68 10 89 f8 e8 85 e1 00 00 b8 37 00 00 00 e8 96 e3 00

I have successfully installed FC2 test1 on this same machine.
Comment 4 Markus Bertheau 2004-05-03 02:31:22 EDT
Re: Summary change (addition of "(ACPI) acpi=off fixes":

I'd rather say workaround instead of fix because sound and battery
status display don't work without ACPI.
Comment 5 Markus Bertheau 2004-05-05 17:47:11 EDT
2.6.5-1.349 doesn't fix this.
Comment 6 paolo borelli 2004-05-06 04:41:59 EDT
Asus M3425 here same problem. From bug 122577, the kernel panic also
happens with FC2 test2 upgraded to rawhide. The first kernel with the
problem is kernel-2.6.5-1.326, kernel-2.6.5-1.322 boots fine.
Comment 7 paolo borelli 2004-05-06 04:43:15 EDT
*** Bug 122577 has been marked as a duplicate of this bug. ***
Comment 8 Matthew Faull 2004-05-09 18:08:37 EDT
My ASUS 5200N(S5N) laptop has the same problem. It has the latest bios
update(0210 release) as of 9th May 2004.

Also when I turn of acpi as a work-around I lose access to the PCMCIA
slot, so thus the external wireless card I use, no longer works as well.
Comment 9 Piotr Malecki 2004-05-17 16:49:31 EDT
Also my ASUS M2400N+ with centrino 1.6 GHz and 512 MB enters kernel
panic when booting without acpi=off. 
 There is no point, of course, to go to kernel 2.6 without acpi.
 Any perspectives?  
 
Comment 10 Alexander Keusch 2004-05-18 02:20:02 EDT
I have the same problem with my Asus M2400N (BIOS ver. 208), but it
works with a 2.6.5 vanilla kernel form kernel.org.
Comment 11 Dave Jones 2004-05-19 08:36:27 EDT
*** Bug 123488 has been marked as a duplicate of this bug. ***
Comment 12 Dave Jones 2004-05-19 08:38:35 EDT
we're going to need to see the ACPI DSDT's of these laptops to get any
further on this. It looks like the cpufreq parser is getting confused
by whatever is in the ACPI tables.

As root do..
cat /proc/acpi/dsdt > dsdt
and attach that to the bug please.
Comment 13 paolo borelli 2004-05-19 10:12:33 EDT
Created attachment 100332 [details]
dsdt for asus m3425ch
Comment 14 Len Brown 2004-05-19 18:28:05 EDT
*** Bug 121328 has been marked as a duplicate of this bug. ***
Comment 15 Matthew Faull 2004-05-19 22:26:32 EDT
Created attachment 100365 [details]
dsdt for an ASUS S5200N with the 210 bios update.
Comment 16 Robert Summers 2004-05-20 00:00:16 EDT
*** Bug 123528 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Bauer 2004-05-20 06:28:26 EDT
Happens still with FC2 final on ASUS S5200N with the 210 bios update
Comment 18 Luming Yu 2004-05-20 07:14:28 EDT
Created attachment 100374 [details]
patch for fixing this oops, against 2.6
Comment 19 sven selle 2004-05-21 03:01:50 EDT
might a dumb question, but how do i apply this patch? do i have to
install the kernelsources and rebuild the kernel?
Comment 20 Len Brown 2004-05-22 01:16:39 EDT
yes, you need to install the kernel source 
cd /usr/src/linux-bla-bla-bla 
patch -Np1 < luming.patch 
and build the kernel the normal way. 
probably a good idea to use the kernel config file that comes with the release. 
 
Comment 21 Matthew Faull 2004-05-22 05:30:12 EDT
Excellent

I just ran that patch against Fedora Linux Kernel 2.6.6-1.368 and did
a build using the i686 config file on my S5200N and the kernel panic
is gone :-)

Thanks Guys 
Comment 22 Alexander Keusch 2004-05-22 14:14:41 EDT
i've tested this patch with 2.6.5-1.358 and it works fine for me too
on my asus m2400n.
Comment 23 Robert Summers 2004-05-25 10:17:28 EDT
Tested patch with 2.6.5-1.358 and it fixes the problem on a Gateway GL450X
Comment 24 Pedro Sobral 2004-05-30 05:27:52 EDT
Hi all,

What can i do in order to install fc2 in a clean Asus s5200N?
I can't boot from FC2 final! Kernel Panic.

Regards,

Pedro
Comment 25 Markus Bertheau 2004-06-01 12:23:52 EDT
Works for me, sound and battery status work now.

Pedro: boot from the first CD and enter linux acpi=off at the boot prompt.

What's still NEEDINFO?
Comment 26 Markus Bertheau 2004-06-01 14:36:33 EDT
I didn't mean to change the status to ASSIGNED; that's bugzilla's
fault. :)
Comment 27 Colin Walters 2004-06-01 14:40:18 EDT
The patch fixes the problem for me as well on a Gateway 450X.
Comment 28 Len Brown 2004-06-04 00:25:05 EDT
*** Bug 124329 has been marked as a duplicate of this bug. ***
Comment 29 paolo borelli 2004-06-16 14:05:44 EDT
Recent kernels (as 2.6.6-1.422) work fine... did the patch went in?
did an alternate fix went in? If so should the above patch go in as well?
Comment 30 Joep Blom 2004-07-16 09:37:45 EDT
I have a 4 year ELSA Motherboard type EP-58 MVP3C-M with a VIA 
chipset.The processor is a K-6 450 MHz.
ALthough ACPI is available, it apparently doesn't comply with the 
Fedora kernel, shipped with version 2.0 (2.6.5-1.358).
As suggested, I started with the command acpi=off and no error 
occurred. However, the PCI ethernet card (3COM 3C905) was not seen 
just as the ISA sound board (Soundblaster AW32).
I would have attached the output of the lspci -vvx command but the 
system off course is not on the network and it's a lot of typing (!).
By the way the standard setup doesn't come with the sources. I assume 
they must be installed from disk 4?
Hope somebody can help me out.
Joep Blom 
Comment 31 igor_pet 2004-08-04 06:35:42 EDT
Asus W1942NWP, BIOS 0202, 04/20/04, FC2 Release - same problem

Note You need to log in before you can comment on or make changes to this bug.