Bug 1243396 - Update Requires from openscap-utils to lightweight openscap-scanner RPM package
Summary: Update Requires from openscap-utils to lightweight openscap-scanner RPM package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scap-security-guide
Version: 6.8
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jan Lieskovsky
QA Contact: Marek Haicman
URL:
Whiteboard:
Depends On:
Blocks: 1172231 1271982
TreeView+ depends on / blocked
 
Reported: 2015-07-15 11:27 UTC by Jan Lieskovsky
Modified: 2020-04-15 14:14 UTC (History)
6 users (show)

Fixed In Version: scap-security-guide-0.1.27-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-10 21:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0846 normal SHIPPED_LIVE scap-security-guide bug fix update 2016-05-10 22:42:59 UTC

Description Jan Lieskovsky 2015-07-15 11:27:56 UTC
Description of problem:
As pointed in comment #25 of bug #1133963 the openscap package include in Red Hat Enterprise Linux 6 Update 7 Beta builds new openscap-scanner package.

scap-security-guide Requires / BuildRequires dependencies should be therefore updated to depend on openscap-scanner package, instead of openscap-utils like currently, since openscap-scanner is lightweight package, not requiring that much RPM dependent packages to be installed.
  

How reproducible:
Always

Steps to Reproduce:
1. Try to install scap-security-guide RPM without the openscap-* toolkit being installed on the system.
2. Notice how openscap-utils package is required to be installed in order to the scap-security-guide RPM could be installed.


Actual results:
scap-security-guide R / BR openscap-utils package.

Expected results:

scap-security-guide R / BR openscap-scanner package.

Comment 7 Marek Haicman 2016-02-16 11:01:14 UTC
Verified that in version scap-security-guide-0.1.28-2.el6 are requirements defined as requested:

Installing:
 scap-security-guide     noarch 0.1.28-2.el6 /scap-security-guide-0.1.28-2.el6.noarch
                                                                           13 M
 scap-security-guide-doc noarch 0.1.28-2.el6 /scap-security-guide-doc-0.1.28-2.el6.noarch
                                                                           14 M
Installing for dependencies:
 openscap                x86_64 1.2.8-2.el6  rhel                         3.9 M
 openscap-scanner        x86_64 1.2.8-2.el6  rhel                          45 k
 xml-common              noarch 0.6.3-33.el6 rhel                          18 k

Comment 9 errata-xmlrpc 2016-05-10 21:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0846.html


Note You need to log in before you can comment on or make changes to this bug.