Bug 1243594 - When deploying from UI we miss to add params based on scale logic
When deploying from UI we miss to add params based on scale logic
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui (Show other bugs)
Director
Unspecified Unspecified
high Severity high
: ga
: Director
Assigned To: Ana Krivokapic
Ola Pavlenko
: Triaged
Depends On: 1245169 1245192 1248089
Blocks: 1250250
  Show dependency treegraph
 
Reported: 2015-07-15 16:59 EDT by Giulio Fidente
Modified: 2015-08-05 09:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-tuskar-ui-0.3.0-12.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1250250 (view as bug list)
Environment:
Last Closed: 2015-08-05 09:59:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 202738 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 13:49:10 EDT

  None (edit)
Description Giulio Fidente 2015-07-15 16:59:59 EDT
Description of problem:
looks like when deploying from UI we do not apply the logic implemented in cli via: https://github.com/rdo-management/python-rdomanager-oscplugin/blob/master/rdomanager_oscplugin/v1/overcloud_deploy.py#L276-L327
Comment 3 Omri Hochman 2015-07-16 10:58:04 EDT
From Ola email:
"HA deployment is not possible via UI : 

osds are timing out because there is no ceph monitor running on controllers, the controllers didn't get the params to deploy ceph so it moved on.

There is some logic in CLI which is not covered in UI."
Comment 8 errata-xmlrpc 2015-08-05 09:59:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549

Note You need to log in before you can comment on or make changes to this bug.