Bug 1245192 - Something went wrong - EndpointNotFound
Summary: Something went wrong - EndpointNotFound
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: Director
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ga
: Director
Assignee: Ryan Brady
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks: 1243056 1243594 1250250
TreeView+ depends on / blocked
 
Reported: 2015-07-21 12:38 UTC by Ola Pavlenko
Modified: 2015-08-05 14:00 UTC (History)
8 users (show)

Fixed In Version: openstack-tuskar-ui-0.3.0-13.el7ost
Doc Type: Bug Fix
Doc Text:
The user interface attempted to connect to the Overcloud keystone-api before the creation and initialization of the corresponding endpoint. The user interface would not find the endpoint the Overcloud would not initialize from the user interface. This fix enables the user interface to properly identify when the Overcloud has not yet been initialized. The error no longer occurs.
Clone Of:
Environment:
Last Closed: 2015-08-05 14:00:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ola Pavlenko 2015-07-21 12:38:10 UTC
Description of problem:
The Undercloud UI is not available after deployment of overcloud.
Getting "Something went wrong message"
In horizon.log:

2015-07-21 12:17:06,116 1117 ERROR django.request Internal Server Error: /dashboard/infrastructure/
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/django/core/handlers/base.py", line 132, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 36, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 84, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 52, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/horizon/decorators.py", line 36, in dec
    return view_func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 71, in view
    return self.dispatch(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/base.py", line 89, in dispatch
    return handler(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/tuskar_ui/infrastructure/overview/views.py", line 147, in get
    return super(IndexView, self).get(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/django/views/generic/edit.py", line 206, in get
    return self.render_to_response(self.get_context_data(form=form))
  File "/usr/lib/python2.7/site-packages/tuskar_boxes/overview/views.py", line 190, in get_context_data
    context = super(IndexView, self).get_context_data(**kwargs)
  File "/usr/lib/python2.7/site-packages/tuskar_ui/infrastructure/overview/views.py", line 154, in get_context_data
    context.update(self.get_data(self.request, context))
  File "/usr/lib/python2.7/site-packages/tuskar_boxes/overview/views.py", line 121, in get_data
    *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/tuskar_ui/infrastructure/overview/views.py", line 220, in get_data
    context['dashboard_urls'] = stack.dashboard_urls
  File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/api/base.py", line 107, in __getattribute__
    return object.__getattribute__(self, attr)
  File "/usr/lib/python2.7/site-packages/tuskar_ui/cached_property.py", line 62, in __get__
    res = instance.__dict__[self.func.__name__] = self.func(instance)
  File "/usr/lib/python2.7/site-packages/tuskar_ui/api/heat.py", line 432, in dashboard_urls
    services = client.services.list()
  File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/services.py", line 32, in list
    return self._list("/OS-KSADM/services", "OS-KSADM:services")
  File "/usr/lib/python2.7/site-packages/keystoneclient/base.py", line 113, in _list
    resp, body = self.client.get(url, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/adapter.py", line 170, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/adapter.py", line 206, in request
    resp = super(LegacyJsonAdapter, self).request(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/adapter.py", line 95, in request
    return self.session.request(url, method, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/utils.py", line 318, in inner
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/session.py", line 337, in request
    raise exceptions.EndpointNotFound()
EndpointNotFound


Version-Release number of selected component (if applicable):
[stack@instack ~]$ rpm -qa | grep rhos
rhos-release-0.65-1.noarch
[stack@instack ~]$ rpm -qa | grep tuskar
python-tuskarclient-0.1.18-3.el7ost.noarch
openstack-tuskar-0.4.18-3.el7ost.noarch
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
openstack-tuskar-ui-0.3.0-12.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1.Using Undercloud UI create 4 flavors, upload images , associate flavors to role , and set node number for controller 1 , for compute 1 and deploy the Overcloud.
2.Wait untill the deployment will successfully finish
3. Go to Overview tab

Actual results:
"Something went wrong" error message.

Expected results:
Overview tab is show 

Additional info:

Comment 3 Hugh Brock 2015-07-22 10:20:56 UTC
Believe this is fixed with the fix for 1236136 -- please recheck against new core puddle.

Comment 4 Mike Burns 2015-07-22 11:23:58 UTC
From talking to Brad yesterday, there is an equivalent fix needed in tuskar-ui.  The same fix doesn't solve the issue.

Also, core puddle version wouldn't matter in this case.

Comment 6 James Slagle 2015-07-23 11:01:18 UTC
should be in POST not MODIFIED, no new build yet

Comment 8 Ola Pavlenko 2015-07-29 16:51:16 UTC
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
openstack-tuskar-ui-0.3.0-13.el7ost.noarch
python-rdomanager-oscplugin-0.0.8-43.el7ost.noarch

Comment 10 errata-xmlrpc 2015-08-05 14:00:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.