Bug 1243922 - Add go-srpm-macros to redhat-rpm-config as a runtime dependency
Summary: Add go-srpm-macros to redhat-rpm-config as a runtime dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Festi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1156129 (view as bug list)
Depends On: 1241156
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-16 15:14 UTC by Jan Chaloupka
Modified: 2015-10-20 02:54 UTC (History)
5 users (show)

Fixed In Version: redhat-rpm-config-29-1.fc22 redhat-rpm-config-29-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-23 08:56:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Chaloupka 2015-07-16 15:14:45 UTC
New package go-srpm-macros providing macros for building golang projects in Fedora for primary and secondary architectures has been created.

As per [1], these macros are needed in order to provide a clean yet reasonable way for packagers to package golang projects for various architectures.

If you see no reason do otherwise can you please add go-srpm-macros as a runtime dependency of redhat-rpm-config for f21, f22, f23 and master branches?

For that case I will create a new bug for removing golang.macros from golang.

[1] https://lists.fedoraproject.org/pipermail/devel/2015-July/212117.html

Thank you
Jan

Comment 1 Vincent Batts 2015-07-16 15:24:25 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1156129

Comment 2 Vincent Batts 2015-07-16 15:26:14 UTC
I'm actively getting the go1.5beta1 ready for rawhide, and could remove the macros if we have a new rpm to put them in. Then we can update the bz1156129 to depend on this new rpm.

Comment 3 Vincent Batts 2015-07-16 15:26:14 UTC
I'm actively getting the go1.5beta1 ready for rawhide, and could remove the macros if we have a new rpm to put them in. Then we can update the bz1156129 to depend on this new rpm.

Comment 4 Fedora Update System 2015-07-17 13:34:56 UTC
redhat-rpm-config-29-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/redhat-rpm-config-29-1.fc22

Comment 5 Fedora Update System 2015-07-17 13:36:36 UTC
redhat-rpm-config-29-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/redhat-rpm-config-29-1.fc21

Comment 6 Florian Festi 2015-07-17 16:07:08 UTC
Can you please make sure that the go-srpm-macros package is actually present in f21!

https://taskotron.fedoraproject.org/taskmaster//builders/x86_64/builds/107048/steps/runtask/logs/stdio

Comment 7 Jan Chaloupka 2015-07-17 20:46:14 UTC
It was build yesterday. Already in updates [1].

Vincent, Florian, can you test it and add +1 karma to both f21 and f22 if the macros are working properly and you don't see any problem? Thanks

[1] https://admin.fedoraproject.org/updates/search/go-srpm-macros

Comment 8 Fedora Update System 2015-07-18 02:04:08 UTC
Package redhat-rpm-config-29-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redhat-rpm-config-29-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11730/redhat-rpm-config-29-1.fc22
then log in and leave karma (feedback).

Comment 9 Jan Chaloupka 2015-07-20 10:23:48 UTC
Both f21 and f22 builds of go-srpm-macros have 3 karmas, just waiting to be pushed to stable.

Comment 10 Vincent Batts 2015-07-20 19:37:41 UTC
*** Bug 1156129 has been marked as a duplicate of this bug. ***

Comment 11 Jan Chaloupka 2015-07-21 08:28:01 UTC
Both f21 and f22 in stable repository.

Comment 12 Fedora Update System 2015-07-23 08:56:35 UTC
redhat-rpm-config-29-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-10-20 02:54:02 UTC
redhat-rpm-config-29-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.