Bug 124394 - assertion triggered in allocated_variable_append:
Summary: assertion triggered in allocated_variable_append:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: make (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-26 10:34 UTC by Rene van Paassen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 11:00:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rene van Paassen 2004-05-26 10:34:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
compiling valgrind produces:

make: expand.c:489: allocated_variable_append: Assertion
`current_variable_set_list->next != 0' failed.

Bug 89206 for Redhat 9 has the same, apparently the rawhide fix was
not ported to FC1

Version-Release number of selected component (if applicable):
make-3.79.1-18

How reproducible:
Always

Steps to Reproduce:
1. download valgrind 2.1.1
2. configure + compile
3.
    

Actual Results:  see above, + it hits the syntax error in timex.h

Expected Results:  compiled valgrind

Additional info:

Comment 1 Rene van Paassen 2004-05-26 11:00:33 UTC
The strangest thing happened. It is apparently due to some unlikely
combination of environment variables. Opened another window and
compilation was successful. 


Note You need to log in before you can comment on or make changes to this bug.