Bug 89206 - allocated_variable_append: Assertion `current_variable_set_list->next != 0' failed
Summary: allocated_variable_append: Assertion `current_variable_set_list->next != 0' f...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: make   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-20 20:45 UTC by Mark Cooke
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-31 05:29:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Cooke 2003-04-20 20:45:54 UTC
Description of problem:
While compiling cvs ffmpeg, 20-Apr-2003, an assertion is triggered from make:

make: expand.c:489: allocated_variable_append: Assertion
`current_variable_set_list->next != 0' failed.
make: *** [lib] Aborted

This assertion has a workaround patch to make posted to the gnu list already.

Version-Release number of selected component (if applicable):
make-3.79.1-17

How reproducible:
Always

Steps to Reproduce:
1. checkout current cvs of ffmpeg on RH9
2. Attempt to build it.
    

Actual Results:  See above

Expected Results:  Make shouldn't have crashed and burnt

Additional info:

Comment 1 Miloslav Trmac 2003-04-20 23:41:57 UTC
Duplicate of bug 88846.

Comment 2 Mark Cooke 2003-04-21 07:22:38 UTC
Just to note that with 3.80, this problem is resolved.

Comment 3 Miloslav Trmac 2003-12-13 14:01:48 UTC
Triage->Close


Note You need to log in before you can comment on or make changes to this bug.