Bug 1244740
| Summary: | HE-RHEVH6.7 | Failed to deploy HE on bonded network infrastructure of RHEVH6.7. | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Red Hat Enterprise Virtualization Manager | Reporter: | Nikolai Sednev <nsednev> | ||||
| Component: | ovirt-hosted-engine-setup | Assignee: | Sandro Bonazzola <sbonazzo> | ||||
| Status: | CLOSED DUPLICATE | QA Contact: | meital avital <mavital> | ||||
| Severity: | urgent | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | 3.5.4 | CC: | danken, ecohen, fdeutsch, gklein, huiwa, juwu, lsurette, mburman, nsednev, ycui, ylavi | ||||
| Target Milestone: | --- | ||||||
| Target Release: | 3.5.4 | ||||||
| Hardware: | x86_64 | ||||||
| OS: | Linux | ||||||
| Whiteboard: | network | ||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | 1235591 | Environment: | |||||
| Last Closed: | 2015-07-23 10:56:37 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Network | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Bug Depends On: | |||||||
| Bug Blocks: | 1059435, 1250199 | ||||||
| Attachments: |
|
||||||
|
Description
Nikolai Sednev
2015-07-20 12:06:19 UTC
could you attach vdsm and supervdsm logs? /var/log/message would be useful, too. (In reply to Dan Kenigsberg from comment #1) > could you attach vdsm and supervdsm logs? > /var/log/message would be useful, too. Hi Huiwa, I only cloned this bug from the original, as you encountered with the same error on bonded network infrastructure. logs are required so can you please provide them? We can't reproduce this report with rhel 6.7 Hosted-engine deploy over bond working as expected, management network is configured with success over bonded interface. Could it be that after creating the bond, it getting other ip from dhcp and then can't be resolved by it's hostname? Created attachment 1055163 [details]
log file
(In reply to Michael Burman from comment #3) > We can't reproduce this report with rhel 6.7 > Hosted-engine deploy over bond working as expected, management network is > configured with success over bonded interface. > > Could it be that after creating the bond, it getting other ip from dhcp and > then can't be resolved by it's hostname? All the hostname is resolved by local. During the creating process, the engine hostname should be resolved. And if the engine can not be resolved, it should report can not reach the engine not the "SSH connection error". So the hostname should not be the point issue. In the logs from comment 4 I see: Thread-16::DEBUG::2015-07-20 02:10:02,925::BindingXMLRPC::1133::vds::(wrapper) client [127.0.0.1]::call setupNetworks with ({'rhevm': {'bonding': 'bond1', 'bootproto': 'dhcp', 'blockingdhcp': True}}, {}, {'connectivityCheck': False}) {} Thread-16::ERROR::2015-07-20 02:10:02,931::BindingXMLRPC::1143::vds::(wrapper) libvirt error Traceback (most recent call last): File "/usr/share/vdsm/rpc/BindingXMLRPC.py", line 1136, in wrapper File "/usr/share/vdsm/rpc/BindingXMLRPC.py", line 554, in setupNetworks File "/usr/share/vdsm/API.py", line 1398, in setupNetworks File "/usr/share/vdsm/supervdsm.py", line 50, in __call__ File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda> File "<string>", line 2, in setupNetworks File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod libvirtError: internal error client socket is closed And thus it looks like a dupe of bug 1206884 to me. *** This bug has been marked as a duplicate of bug 1206884 *** |