Bug 1245231 - Content Dashboard: "Sync Overview" widget has what seems like a permanent spinner, shows no data.
Summary: Content Dashboard: "Sync Overview" widget has what seems like a permanent sp...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
David O'Brien
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-07-21 14:13 UTC by Corey Welton
Modified: 2017-02-23 19:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 16:04:05 UTC


Attachments (Terms of Use)
screenshot (29.96 KB, image/png)
2015-07-21 14:16 UTC, Corey Welton
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11234 None None None 2016-04-22 14:53:25 UTC

Description Corey Welton 2015-07-21 14:13:30 UTC
Description of problem:


The "Sync Overview" widget contains nothing but a spinner.

Version-Release number of selected component (if applicable):
Snap 13

How reproducible:


Steps to Reproduce:
1.  Assure some content has been synced in the past for an org, but assure that nothing is actually syncing at the moment.
2.  Go to Content Dashboard
3.  Look at "Sync Overview" widget.

Actual results:

Permanent spinner; no content

Expected results:

Widget works.  Also, we probably shouldn't be passing an ISE as an informational error in the logs (see below)


Additional info:

* All server statuses (`katello-service status`) seem to be ok.

* /var/log/foreman/production.log:

2015-07-21 10:07:28 [I] Processing by Katello::DashboardController#errata as */*
2015-07-21 10:07:28 [I]   Parameters: {"undefined"=>"-1"}
2015-07-21 10:07:28 [I] Client connected.
2015-07-21 10:07:28 [I] Client connected.
2015-07-21 10:07:28 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_host_collections.html.haml (6.2ms)
2015-07-21 10:07:28 [I] Completed 200 OK in 658ms (Views: 299.1ms | ActiveRecord: 10.0ms)
2015-07-21 10:07:28 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_subscriptions_totals.haml (80.5ms)
2015-07-21 10:07:28 [I] Completed 200 OK in 890ms (Views: 81.2ms | ActiveRecord: 2.8ms)
2015-07-21 10:07:29 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_errata.haml (11.9ms)
2015-07-21 10:07:29 [I] Completed 200 OK in 627ms (Views: 257.2ms | ActiveRecord: 13.0ms)
2015-07-21 10:10:15 [I] Processing by Katello::DashboardController#index as HTML
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/common/_helptip_button.html.haml (0.7ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/common/_helptip.html.haml (0.8ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_subscriptions.haml (77.8ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_entry.html.haml (80.8ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_ajax_entry.html.haml (2.1ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_ajax_entry.html.haml (0.3ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_ajax_entry.html.haml (0.3ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_ajax_entry.html.haml (0.3ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_ajax_entry.html.haml (0.3ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/index.html.haml within katello/layouts/katello (102.9ms)
2015-07-21 10:10:15 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/common/_common_i18n.html.haml (9.7ms)
2015-07-21 10:10:15 [I]   Rendered home/_submenu.html.erb (2.9ms)
2015-07-21 10:10:15 [I]   Rendered home/_user_dropdown.html.erb (12.3ms)
2015-07-21 10:10:15 [I] Read fragment views/tabs_and_title_records-3 (0.1ms)
2015-07-21 10:10:15 [I]   Rendered home/_topbar.html.erb (137.1ms)
2015-07-21 10:10:15 [I]   Rendered layouts/base.html.erb (139.2ms)
2015-07-21 10:10:15 [I] Completed 200 OK in 434ms (Views: 258.7ms | ActiveRecord: 1.4ms)
2015-07-21 10:10:16 [I] Processing by Katello::DashboardController#host_collections as */*
2015-07-21 10:10:16 [I]   Parameters: {"undefined"=>"-1"}
2015-07-21 10:10:16 [I] Processing by Katello::DashboardController#content_views as */*
2015-07-21 10:10:16 [I]   Parameters: {"undefined"=>"-1"}
2015-07-21 10:10:16 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_host_collections.html.haml (1.3ms)
2015-07-21 10:10:16 [I] Completed 200 OK in 11ms (Views: 1.6ms | ActiveRecord: 1.6ms)
2015-07-21 10:10:16 [I] Processing by Katello::DashboardController#errata as */*
2015-07-21 10:10:16 [I]   Parameters: {"undefined"=>"-1"}
2015-07-21 10:10:16 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_errata.haml (11.7ms)
2015-07-21 10:10:16 [I] Completed 200 OK in 40ms (Views: 15.2ms | ActiveRecord: 6.1ms)
2015-07-21 10:10:16 [I] Processing by Katello::DashboardController#subscriptions_totals as */*
2015-07-21 10:10:16 [I]   Parameters: {"undefined"=>"-1"}
2015-07-21 10:10:16 [I] Processing by Katello::DashboardController#sync as */*
2015-07-21 10:10:16 [I]   Parameters: {"undefined"=>"-1"}
2015-07-21 10:10:19 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_content_views.haml (2791.5ms)
2015-07-21 10:10:19 [I] Completed 200 OK in 2811ms (Views: 2789.9ms | ActiveRecord: 11.5ms)
2015-07-21 10:10:19 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_subscriptions_totals.haml (2568.6ms)
2015-07-21 10:10:19 [I] Completed 200 OK in 3671ms (Views: 2576.5ms | ActiveRecord: 4.0ms)
2015-07-21 10:10:20 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.58/app/views/katello/dashboard/_sync.haml (3205.3ms)
2015-07-21 10:10:20 [I] Completed 500 Internal Server Error in 3860ms
2015-07-21 10:10:20 [F] 
NoMethodError (undefined method `start_time' for #<Hash:0x0000000ff11f30>):
  lib/middleware/catch_json_parse_errors.rb:9:in `call'

Comment 1 Corey Welton 2015-07-21 14:16:05 UTC
Created attachment 1054414 [details]
screenshot

Comment 4 Brad Buckingham 2015-07-28 14:32:10 UTC
Created redmine issue http://projects.theforeman.org/issues/11234 from this bug

Comment 5 Brad Buckingham 2015-07-28 14:55:31 UTC
katello PR: https://github.com/Katello/katello/pull/5381

Comment 6 Bryan Kearney 2015-07-28 16:11:05 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11234 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|341cbefca4e6d454e4d483dda87689b9d9360543.

Comment 8 Corey Welton 2015-07-30 01:48:13 UTC
Verified in Snap 15, no longer do we get a stuck cursor.  Content properly appears.

Comment 9 Bryan Kearney 2015-08-12 16:04:05 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.