Bug 1245250 - [RFE] unbound does not support ECDSA DNSSEC keys (RFC 6605)
Summary: [RFE] unbound does not support ECDSA DNSSEC keys (RFC 6605)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: unbound
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Tomáš Hozza 🤓
QA Contact: Radka Skvarilova
Marc Muehlfeld
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On: 1265605
Blocks: 1289025 1305230
TreeView+ depends on / blocked
 
Reported: 2015-07-21 14:45 UTC by Petr Spacek
Modified: 2019-07-11 09:40 UTC (History)
7 users (show)

(edit)
The Unbound DNS validating resolver now supports ECDSA cipher for DNSSEC

This update enables the ECDSA cipher in the Unbound DNS validating resolver. As a result, the DNS resolver is now able to validate DNS responses signed
using DNSSEC with ECDSA algorithm.
Clone Of:
: 1265605 (view as bug list)
(edit)
Last Closed: 2016-11-04 06:04:36 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2407 normal SHIPPED_LIVE unbound enhancement update 2016-11-03 13:56:48 UTC

Description Petr Spacek 2015-07-21 14:45:45 UTC
Description of problem:
Unbound in RHEL is compiled with option --disable-ecdsa which effectivelly disables support for RFC 6605.

This is going to cause interoperability problems in near future because ECDSA algorithms are going to be deployed at scale e.g. by Cloudflare.

Version-Release number of selected component (if applicable):
1.4.20-23

How reproducible:
100 %

Steps to Reproduce:
0. Install unbound with default configuration and run it
1. Attempt to validate domain which is DNSSEC-signed using one of ECDSA algorithms. See below.

Actual results:
$ dig @127.0.0.1 ds-4.alg-14-nsec.dnssec-test.org
[...]
;; flags: qr rd ra;

Flags in the answer do not contain AD bit, so apparently the answer was not validated by Unbound. The test domain is signed using ECDSA alg # 14:
http://www.iana.org/assignments/dns-sec-alg-numbers/dns-sec-alg-numbers.xhtml#dns-sec-alg-numbers-1


Expected results:
$ dig @127.0.0.1 ds-4.alg-14-nsec.dnssec-test.org
[...]
;; flags: qr rd ra ad;

AD bit is set, i.e. the validation passed.

Additional info:
bind-9.9.4-18.el7_1.2.x86_64 in RHEL 7 supports ECDSA and validates the data properly. Not supporting ECDSA in Unbound will give uneven experience (interoperability problems aside).

Comment 10 errata-xmlrpc 2016-11-04 06:04:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2407.html


Note You need to log in before you can comment on or make changes to this bug.