Bug 124531 - Cleaned up comps.xml that came on FC2 Final Disc 1
Summary: Cleaned up comps.xml that came on FC2 Final Disc 1
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 2
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-27 10:13 UTC by Justin Szeto
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-05-27 21:45:16 UTC


Attachments (Terms of Use)
comps.xml cleaned up (410.14 KB, text/xml)
2004-05-27 10:16 UTC, Justin Szeto
no flags Details

Description Justin Szeto 2004-05-27 10:13:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Hi Red Hat.
This is not really a bug. I decided to clean up comps.xml for my own
purposes and since then decided maybe, maybe not, you might find it
helpful/useful... I hope! :) I did the following:
1. Deleted 12 blank lines.
2. Removed some trailing spaces.
3. Tags are ALWAYS in the same sequence for every <group>.
4. Within each <packagelist> tag, I alphabetically sorted the
<packagereq> tags.
5. I moved all <name> and <description> tags with xml:lang attributes
to the end of each <group> to make the file more readable.
So no information was actually changed or deleted in the file, I
simply moved lines here and there within each <group>. I think the
result is much more readable and consistent. I have run
system-config-packages using this file and it runs just as the
original comps.xml file.


Version-Release number of selected component (if applicable):
comps-2-0.20040513

How reproducible:
Always

Steps to Reproduce:
Not Applicable
    

Additional info:

Comment 1 Justin Szeto 2004-05-27 10:16:06 UTC
Created attachment 100622 [details]
comps.xml cleaned up

Here is the comps.xml file cleaned up, you can do with it whatever... I just
think it is much more consistent and readable...

Comment 2 Bill Nottingham 2004-05-27 21:45:16 UTC
Unfortunately, the translations are added by intltool out of a munged
file, so this really can't be added back in sanely.


Note You need to log in before you can comment on or make changes to this bug.