Bug 1245547 - sharding - Fix unlink of sparse files
Summary: sharding - Fix unlink of sparse files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: sharding
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1247014
TreeView+ depends on / blocked
 
Reported: 2015-07-22 09:25 UTC by Krutika Dhananjay
Modified: 2016-06-16 13:26 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1247014 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:26:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-07-22 09:25:19 UTC
Description of problem:
In a sharded volume, unlink of files with holes fails with ENOENT.
This is because shard_common_lookup_shards() treats absence of participant shards as failure. But in case of files with holes, it is possible for most shards to not exist. And shard translator must not fail unlinks and renames (where the dst exists && is sharded && has holes).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-07-22 09:51:36 UTC
REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename()) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Anand Avati 2015-07-22 11:19:55 UTC
REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Anand Avati 2015-07-23 01:41:48 UTC
REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename()) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Anand Avati 2015-07-23 04:07:39 UTC
REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 5 Anand Avati 2015-07-24 01:43:11 UTC
REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 6 Anand Avati 2015-07-27 07:33:03 UTC
COMMIT: http://review.gluster.org/11737 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 385acc675c512c63f7051d46ad96666ea34cf0b5
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jul 22 15:18:20 2015 +0530

    features/shard: Handle unlink of files with holes appropriately in unlink() and rename().
    
    Change-Id: I25a02386dc95580c2e76a13fdd8e11a0df234d56
    BUG: 1245547
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11737
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 15:20:08 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 13:26:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.