Bug 1247014 - sharding - Fix unlink of sparse files
Summary: sharding - Fix unlink of sparse files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: sharding
Version: 3.7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1245547
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-27 07:15 UTC by Krutika Dhananjay
Modified: 2015-09-09 09:38 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1245547
Environment:
Last Closed: 2015-09-09 09:38:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-07-27 07:15:43 UTC
+++ This bug was initially created as a clone of Bug #1245547 +++

Description of problem:
In a sharded volume, unlink of files with holes fails with ENOENT.
This is because shard_common_lookup_shards() treats absence of participant shards as failure. But in case of files with holes, it is possible for most shards to not exist. And shard translator must not fail unlinks and renames (where the dst exists && is sharded && has holes).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-22 05:51:36 EDT ---

REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename()) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-07-22 07:19:55 EDT ---

REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-07-22 21:41:48 EDT ---

REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename()) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-07-23 00:07:39 EDT ---

REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-07-23 21:43:11 EDT ---

REVIEW: http://review.gluster.org/11737 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 1 Anand Avati 2015-07-27 08:44:10 UTC
REVIEW: http://review.gluster.org/11767 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Anand Avati 2015-07-29 03:44:48 UTC
REVIEW: http://review.gluster.org/11767 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Anand Avati 2015-07-29 10:49:05 UTC
REVIEW: http://review.gluster.org/11767 (features/shard: Handle unlink of files with holes appropriately in unlink() and rename().) posted (#3) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Anand Avati 2015-07-30 07:29:16 UTC
COMMIT: http://review.gluster.org/11767 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fc62b329ad6dc5f2e986f5cd50225015c3af199e
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jul 22 15:18:20 2015 +0530

    features/shard: Handle unlink of files with holes appropriately in unlink() and rename().
    
            Backport of: http://review.gluster.org/11737
    
    Change-Id: I94b089dc943ca20952834aa513134f7b9e925bd4
    BUG: 1247014
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11767
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 5 Kaushal 2015-09-09 09:38:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.