Bug 1245596 - OpenId traceback in http log
Summary: OpenId traceback in http log
Keywords:
Status: CLOSED DUPLICATE of bug 1130066
Alias: None
Product: Copr
Classification: Community
Component: frontend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Valentin Gologuzov
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-22 10:55 UTC by Miroslav Suchý
Modified: 2015-12-01 06:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-23 08:21:28 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2015-07-22 10:55:53 UTC
I can see in /var/log/httpd/error_log:
[Wed Jul 22 10:43:34.764952 2015] [wsgi:error] [pid 3301] Traceback (most recent call last):
[Wed Jul 22 10:43:34.764954 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 933, in _verifyDiscoveryResultsOpenID2
[Wed Jul 22 10:43:34.764957 2015] [wsgi:error] [pid 3301]     self._verifyDiscoverySingle(endpoint, to_match)
[Wed Jul 22 10:43:34.764959 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 1006, in _verifyDiscoverySingle
[Wed Jul 22 10:43:34.764961 2015] [wsgi:error] [pid 3301]     raise TypeURIMismatch(type_uri, endpoint)
[Wed Jul 22 10:43:34.764964 2015] [wsgi:error] [pid 3301] TypeURIMismatch: <openid.consumer.consumer.TypeURIMismatch: Required type http://specs.openid.net/auth/2.0/signon not found in ['http://specs.openid.net/auth/2.0/server', 'http://openid.net/server/1.0', 'http://ns.launchpad.net/2007/openid-teams', 'http://fedoraproject.org/specs/open_id/cla', 'http://openid.net/srv/ax/1.0', 'http://openid.net/extensions/sreg/1.1', 'http://openid.net/sreg/1.0'] for endpoint <openid.consumer.discover.OpenIDServiceEndpoint server_url='https://id.fedoraproject.org/openid/' claimed_id=None local_id=None canonicalID=None used_yadis=True >>
[Wed Jul 22 10:43:43.867174 2015] [wsgi:error] [pid 3301] ERROR:root:Error attempting to use stored discovery information: <openid.consumer.consumer.TypeURIMismatch: Required type http://specs.openid.net/auth/2.0/signon not found in ['http://specs.openid.net/auth/2.0/server', 'http://openid.net/server/1.0', 'http://ns.launchpad.net/2007/openid-teams', 'http://fedoraproject.org/specs/open_id/cla', 'http://openid.net/srv/ax/1.0', 'http://openid.net/extensions/sreg/1.1', 'http://openid.net/sreg/1.0'] for endpoint <openid.consumer.discover.OpenIDServiceEndpoint server_url='https://id.fedoraproject.org/openid/' claimed_id=None local_id=None canonicalID=None used_yadis=True >>
[Wed Jul 22 10:43:43.867209 2015] [wsgi:error] [pid 3301] Traceback (most recent call last):
[Wed Jul 22 10:43:43.867211 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 933, in _verifyDiscoveryResultsOpenID2
[Wed Jul 22 10:43:43.867213 2015] [wsgi:error] [pid 3301]     self._verifyDiscoverySingle(endpoint, to_match)
[Wed Jul 22 10:43:43.867215 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 1006, in _verifyDiscoverySingle
[Wed Jul 22 10:43:43.867217 2015] [wsgi:error] [pid 3301]     raise TypeURIMismatch(type_uri, endpoint)
[Wed Jul 22 10:43:43.867219 2015] [wsgi:error] [pid 3301] TypeURIMismatch: <openid.consumer.consumer.TypeURIMismatch: Required type http://specs.openid.net/auth/2.0/signon not found in ['http://specs.openid.net/auth/2.0/server', 'http://openid.net/server/1.0', 'http://ns.launchpad.net/2007/openid-teams', 'http://fedoraproject.org/specs/open_id/cla', 'http://openid.net/srv/ax/1.0', 'http://openid.net/extensions/sreg/1.1', 'http://openid.net/sreg/1.0'] for endpoint <openid.consumer.discover.OpenIDServiceEndpoint server_url='https://id.fedoraproject.org/openid/' claimed_id=None local_id=None canonicalID=None used_yadis=True >>
[Wed Jul 22 10:44:05.624491 2015] [wsgi:error] [pid 3301] ERROR:coprs:Exception on /login/ [GET]
[Wed Jul 22 10:44:06.010819 2015] [wsgi:error] [pid 3301] Traceback (most recent call last):
[Wed Jul 22 10:44:06.010842 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/flask/app.py", line 1817, in wsgi_app
[Wed Jul 22 10:44:06.010845 2015] [wsgi:error] [pid 3301]     response = self.full_dispatch_request()
[Wed Jul 22 10:44:06.010848 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/flask/app.py", line 1477, in full_dispatch_request
[Wed Jul 22 10:44:06.010851 2015] [wsgi:error] [pid 3301]     rv = self.handle_user_exception(e)
[Wed Jul 22 10:44:06.010853 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/flask/app.py", line 1381, in handle_user_exception
[Wed Jul 22 10:44:06.010855 2015] [wsgi:error] [pid 3301]     reraise(exc_type, exc_value, tb)
[Wed Jul 22 10:44:06.010858 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/flask/app.py", line 1475, in full_dispatch_request
[Wed Jul 22 10:44:06.010860 2015] [wsgi:error] [pid 3301]     rv = self.dispatch_request()
[Wed Jul 22 10:44:06.010862 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/flask/app.py", line 1461, in dispatch_request
[Wed Jul 22 10:44:06.010865 2015] [wsgi:error] [pid 3301]     return self.view_functions[rule.endpoint](**req.view_args)
[Wed Jul 22 10:44:06.010867 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/flask_openid.py", line 499, in decorated
[Wed Jul 22 10:44:06.010869 2015] [wsgi:error] [pid 3301]     openid_response = consumer.complete(args, self.get_current_url())
[Wed Jul 22 10:44:06.010872 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 415, in complete
[Wed Jul 22 10:44:06.010874 2015] [wsgi:error] [pid 3301]     response = self.consumer.complete(message, endpoint, current_url)
[Wed Jul 22 10:44:06.010876 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 620, in complete
[Wed Jul 22 10:44:06.010878 2015] [wsgi:error] [pid 3301]     return modeMethod(message, endpoint, return_to)
[Wed Jul 22 10:44:06.010880 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 647, in _complete_id_res
[Wed Jul 22 10:44:06.010883 2015] [wsgi:error] [pid 3301]     return self._doIdRes(message, endpoint, return_to)
[Wed Jul 22 10:44:06.010885 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 731, in _doIdRes
[Wed Jul 22 10:44:06.010887 2015] [wsgi:error] [pid 3301]     endpoint = self._verifyDiscoveryResults(message, endpoint)
[Wed Jul 22 10:44:06.010897 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 888, in _verifyDiscoveryResults
[Wed Jul 22 10:44:06.010899 2015] [wsgi:error] [pid 3301]     return self._verifyDiscoveryResultsOpenID2(resp_msg, endpoint)
[Wed Jul 22 10:44:06.010901 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 940, in _verifyDiscoveryResultsOpenID2
[Wed Jul 22 10:44:06.010903 2015] [wsgi:error] [pid 3301]     to_match.claimed_id, [to_match])
[Wed Jul 22 10:44:06.010905 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/consumer.py", line 1053, in _discoverAndVerify
[Wed Jul 22 10:44:06.010907 2015] [wsgi:error] [pid 3301]     _, services = self._discover(claimed_id)
[Wed Jul 22 10:44:06.010908 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/discover.py", line 471, in discover
[Wed Jul 22 10:44:06.010910 2015] [wsgi:error] [pid 3301]     return discoverURI(identifier)
[Wed Jul 22 10:44:06.010912 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/discover.py", line 463, in discoverURI
[Wed Jul 22 10:44:06.010914 2015] [wsgi:error] [pid 3301]     claimed_id, openid_services = discoverYadis(uri)
[Wed Jul 22 10:44:06.010916 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/consumer/discover.py", line 390, in discoverYadis
[Wed Jul 22 10:44:06.010918 2015] [wsgi:error] [pid 3301]     response = yadisDiscover(uri)
[Wed Jul 22 10:44:06.010919 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/yadis/discover.py", line 88, in discover
[Wed Jul 22 10:44:06.010921 2015] [wsgi:error] [pid 3301]     resp = fetchers.fetch(result.xrds_uri)
[Wed Jul 22 10:44:06.010923 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/fetchers.py", line 42, in fetch
[Wed Jul 22 10:44:06.010925 2015] [wsgi:error] [pid 3301]     return fetcher.fetch(url, body, headers)
[Wed Jul 22 10:44:06.010927 2015] [wsgi:error] [pid 3301]   File "/usr/lib/python2.7/site-packages/openid/fetchers.py", line 184, in fetch
[Wed Jul 22 10:44:06.010929 2015] [wsgi:error] [pid 3301]     raise HTTPFetchingError(why=exc_inst)
[Wed Jul 22 10:44:06.010931 2015] [wsgi:error] [pid 3301] HTTPFetchingError: (28, 'Connection timed out after 20001 milliseconds')
[Wed Jul 22 10:44:54.026346 2015] [wsgi:error] [pid 3301] /usr/lib64/python2.7/site-packages/sqlalchemy/sql/default_comparator.py:35: SAWarning: The IN-predicate on "counter_stat.name" was invoked with an empty sequence. This results in a contradiction, which nonetheless can be expensive to evaluate.  Consider alternative strategies for improved performance.
[Wed Jul 22 10:44:54.026374 2015] [wsgi:error] [pid 3301]   return o[0](self, self.expr, op, *(other + o[1:]), **kwargs)
[Wed Jul 22 10:46:48.688703 2015] [wsgi:error] [pid 3301] ERROR:root:Error attempting to use stored discovery information: <openid.consumer.consumer.TypeURIMismatch: Required type http://specs.openid.net/auth/2.0/signon not found in ['http://specs.openid.net/auth/2.0/server', 'http://openid.net/server/1.0', 'http://ns.launchpad.net/2007/openid-teams', 'http://fedoraproject.org/specs/open_id/cla', 'http://openid.net/srv/ax/1.0', 'http://openid.net/extensions/sreg/1.1', 'http://openid.net/sreg/1.0'] for endpoint <openid.consumer.discover.OpenIDServiceEndpoint server_url='https://id.fedoraproject.org/openid/' claimed_id=None local_id=None canonicalID=None used_yadis=True >>

Comment 1 Valentin Gologuzov 2015-07-23 08:21:28 UTC

*** This bug has been marked as a duplicate of bug 1130066 ***


Note You need to log in before you can comment on or make changes to this bug.