Bug 1245810 - Adding ECC support to OpenJDK 8 through NSS+SunEC
Summary: Adding ECC support to OpenJDK 8 through NSS+SunEC
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.8.0-openjdk   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andrew John Hughes
QA Contact: Lukas Zachar
Robert Krátký
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1297579 1313485
TreeView+ depends on / blocked
 
Reported: 2015-07-22 20:45 UTC by Andrew John Hughes
Modified: 2016-11-03 22:55 UTC (History)
9 users (show)

Fixed In Version: java-1.8.0-openjdk-1.8.0.72-4.b15.el7
Doc Type: Release Note
Doc Text:
*OpenJDK 8* now supports ECC With this update, support for Elliptic Curve Cryptography (ECC) and associated ciphers for TLS connections has been added to *OpenJDK 8*. In most cases, ECC is preferable to older cryptographic solutions for establishing secure network connections.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:55:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2139 normal SHIPPED_LIVE java-1.8.0-openjdk bug fix and enhancement update 2016-11-03 13:12:04 UTC

Description Andrew John Hughes 2015-07-22 20:45:38 UTC
This is a clone of bug 1208307 which makes the same change on RHEL 6.

It follows bug 1121210 which added elliptic curve cryptography support in OpenJDK 7 for RHEL 7.2.

Comment 5 John Horne 2016-07-04 14:51:29 UTC
Can I ask what is happening with this bug fix?
It says it is fixed in version java-1.8.0-openjdk-1.8.0.72-4.b15.el7 but we are already on version java-1.8.0-openjdk-1.8.0.91-1.b14.el7_2 and ECC is still disabled.

Comment 6 Andrew John Hughes 2016-07-04 15:11:33 UTC
The fix is scheduled for release in RHEL 7.3.

java-1.8.0-openjdk-1.8.0.72-4.b15.el7 is a RHEL 7.3 RPM.
java-1.8.0-openjdk-1.8.0.91-1.b14.el7_2 is a RHEL 7.2 RPM.

Comment 9 errata-xmlrpc 2016-11-03 22:55:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2139.html


Note You need to log in before you can comment on or make changes to this bug.