Bug 124655 - spadmin file needed to configure printer/fax is missing
spadmin file needed to configure printer/fax is missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 05:22 EDT by Honza
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 11:46:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza 2004-05-28 05:22:29 EDT
Description of problem:
The file spadmin is missing. It is needed for configuring ad adding
printers. This file is explicitely mentioned in the OO help, so it
should be there. In the FC1 this file existed and worked, in FC2
doesn't exist at all.
Using previous-version psprint.conf config file doesn't wor too (both
in home directory and basic directory).
Version-Release number of selected component (if applicable):1.1.1-4


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marius Andreiana 2004-05-30 07:37:22 EDT
Is this still needed? I added a printer via RH print manager (cups)
and it's seen by OOo.
Comment 2 Honza 2004-05-30 09:36:30 EDT
Unfortunately, I'm not able to add printer using RH - I use rlpr command. I know there is 
a way to use local lpd command for remote print, but I didn't succeed in using it.
Comment 3 Marius Andreiana 2004-05-30 11:20:39 EDT
Can you add the printer manually to /etc/cups/cupsd.conf? That's where
from all system sees it. OOo should see it too (if not, i guess it's a
bug)
Comment 4 Marius Andreiana 2004-05-30 12:30:01 EDT
Hm, just noticed:

1. File -> Printer settings, and then Properties for current printer
doesn't do anything (hangs for a while and that's it)

2. When printing, all page looks like it's moved up, i.e. only a part
of the header appears and there's more free space at bottom. Exporting
to PDF and printing from Acrobat Reader is ok.
Comment 5 Marco Colombo 2004-06-01 11:31:07 EDT
I can confirm 1. - the printer is a Samsung ML-1210, but it doesn't
seem to make any difference. I've tried deleting it, and thus using the
generic printer under oo, but still the Properties dialog won't open
at all (yes, it seems to be looking for something for a little while but
nothing happens). The same procedure works in FC1 and oo1.1.0.
Comment 6 Roger Pfister 2004-06-02 05:22:36 EDT
Same problem with me. File -> Printer settings, and then Properties
for current printer doesn't do anything (hangs for a while and that's
it). HP LaserJet.
Comment 7 Roger Pfister 2004-06-02 05:43:29 EDT
With spadmin it was possible to specify the print command. I would
like to use kprinter and not CUPS directly. Now i can't sepcify this
anymore.
Comment 8 Joe (theWordy) Philbrook 2004-06-02 20:31:47 EDT
Yes this file is VERY needed. It is the official way to add a fax
driver to ooffice. It is still explicitly listed in several places in
oo's help text. With ooffice 1.1.0 I used the spadmin -> add printer
-> fax to set up an send fax script. Then when I would print a
document to the "fax" printer ooffice took care of all the file
conversions and file clean up in the background. The resulting fax
machine output was also reportedly easier to read than when the same
document was exported to pdf, then converted to postscript, and
manually fed to the fax send script. So unless there is a simple to
use fax send driver for cups, then spadmin is (to me) very much needed.
Comment 9 Colin Charles 2004-06-09 11:08:05 EDT
It is also the correct way to add PDF exporting capability. Its a
feature still available in upstream OOo 1.1.2 release candidates, so
spadmin is very much needed.

Dan, in the huge OOo upgrade thats happening, will this be fixed?
Comment 10 Marco Colombo 2004-06-09 14:22:29 EDT
Dan, does it make sense to split this bug in two? The spadmin issue
seems to be unrelated to the broken Properties dialog, even if 
they may have common roots in the recent changes to the OOo printers
handling.
Here we have:
- per user vs. system-wide printer setup: I don't know if the usual
  configuration tools allows _users_ to change any printer option.
  I think they require root access.
- per job priter options: that's the big problem I have now, I'd like
  to be able to set the paper tray, each time I print something, from
  inside the print dialog, without having to fire any external
  printer setup tool, not to mention it requires root access.

The two issues are unrelated, I am willing to wait for a better
printer setup tool that allows some settings to be set 'per user',
but the requirement to run a system level utility to set _per job_
settings instead of the 'Properties' dialog it's a _design_ nonsense,
not a temporary inconvenience, IMHO.
Comment 11 David 2004-07-11 14:15:50 EDT
Hi!

I tried to install the (working well in FC1) excellent extendedPDF
macro (http://www.jdisoftware.co.uk/pages/epdf-home.php) and stumped
across the missing spadmin which is needed for it to work :-(

It would be great if FC2 would bring extendedPDF by default as it
produces much more configurable/richer PDF files (one can preserve
links, for example).

Best regards,
David
Comment 12 P. Scott DeVos 2004-08-05 11:25:17 EDT
I need this file, too.  I like to have all my printing go to kprinter
before I send it to the actual printer.  As far as I know, spadmin is
the only way to do this.

What's more, I can't just copy files from an earlier release of
Fedora, because my new laptop is running FC2 x86_64.  Ooo does not
release a 64bit binary, so my only other alternative is to compile
from binary.
Comment 13 Miguel Freitas 2004-09-15 11:33:58 EDT
I'd like to add another request for putting spadmin back in.

I have been compiling my own openoffice rpms using the redhat srpm as
base, but excluding the OOoCUPS patch from the ooo-build. These rpms
include spadmin and are built for fedora core 1 (both ooo 1.1.1 and
1.1.2):

http://cambuca.ldhs.cetuc.puc-rio.br/nobackup/OpenOffice/

While i appreciate the easiness of installation that redhat/fedora
openoffice package provides (automatically using installed cups
printers), there must be no prejudice to the existing flexibility. I
consider a mistake from whoever did the OOoCUPS patch or ooo-build to
have removed the old spadmin support.

I personally prefer to have all my printing centered on a single
interface provided by kprinter. Not only that, but i've been able to
produce better pdfs using kprinter filters than ooo's pdf export. And
what about printing 4 pages per sheet?

It's all about the freedom to choose. i'm just a user here, it would
be really nice if i didn't have to patch/recompile openoffice every
time a new release is out.
Comment 14 Dan Williams 2004-09-15 12:19:33 EDT
Guys, you're out of luck for 2.0 anyway, since it only allows you (at
first glance) to add Fax and PDF printers.
Comment 15 Marc Schwartz 2004-09-15 14:02:04 EDT
I don't mind the tighter OO.org integration with CUPS, as long as it
is not brain-dead the way it is at the moment.

To have a single common mechanism to add or manage printers is
entirely reasonable.

However, if I need to modify the printer settings (ie. paper layout,
media type, printer tray, etc.) for a particular document, it should
work within the application. Right now it does not by default with
OO.org under FC2.

Until this is resolved, I have simply gone back to the OO.org
installation tarball. Not to mention, the OO.org implementation loads
and operates notably faster (an issue that I see was posted again to
the FC list today). Of course, I miss the pretty icons that the FC
version has... :-)

For now, when I need to make any printer modifications, I use the
gnome-print-manager. Yes, it is a pain, but it works and OO.org will
respect those settings when I print. I used to use the CUPS browser
interface under the prior versions of FC and RH. The one nice thing
under FC2 is the ability to import a PPD file, that is not available
from the default CUPS install.

The other thing that works better with spadmin, is the ability to
print documents with embedded EPS images right to PDF files using the
Distiller driver as a printer. The normal PDF Export mechanism did not
do the proper conversion of the EPS files. I would have to print to a
PS file and then use ps2pdf.

Lastly, printing color documents to my Oki7400n color laser works with
the OO.org install. Using the FC default install, color documents
printed from OO.org would be black and white (or grayscale).
Curiously, if I exported the color document to a PDF file and printed
the PDF file from Acrobat Reader, it came out in color. Go figure.

Hopefully, this all will work better in FC3?
Comment 16 Ames 2004-10-21 18:14:12 EDT
Dan, AFAIK, spadmin is REQUIRED by oo to set up printing to a remote
fax server.  Without it, you cannot specify the fax phone number when
you print.  You say we're out of luck for 2.0 -- how should we print
to a fax server in fc2??
Comment 17 Marc Schwartz 2004-10-21 22:40:19 EDT
In light of my prior comments, I just want to go on record as noting
that today's update is a major improvement and to say thanks!

The majority of printing problems (including the color printing) that
I noted above are now resolved with the new update.

The only lingering issue is the printing of embedded EPS graphics in a
document to a PDF export, which still only shows as a placeholder in
the PDF document. Is there a way to add the distiller type of
functionality that is available in the OO.org version using spadmin?
There is still the print to PS + ps2pdf workaround for now.

Thanks Dan!
Comment 18 Caolan McNamara 2004-12-10 09:03:48 EST
1. The broken properties dialog thing is gone, along with most of the
out and out bugs.
2. We could fix the help with the patch on bug #126701, so track that
bug for "help is wrong"
3. cmc->marc: For the lingering embedded EPS problem, I suggest
opening a seperate bug for that with an attached simple example
document which shows the problem.
4. For printing to a fax, maybe the solution should be a fax CUPS
driver to be available, maybe fax4CUPS. Perhaps we should simply open
a "make it easy to setup sending a fax through cups" against the CUPS
people.
Comment 19 Marc Schwartz 2004-12-10 09:34:31 EST
Caolan,

A quick query before creating a new BZ entry as you suggest.

With the recent changes (under FC 3) and the return of the PDF
Converter printer type, I can print embedded EPS files that show
properly in the output PDF file. The problem is only when using the
PDF Export option. 

I am not sufficiently clear on the distinctions between the two PDF
generating methods to better understand why it works with one and not
the other.

I just wanted to provide the additional information and to confirm
that this issue still warrants a separate bug report, since the PDF
Export issue has been a 'problem' for some time. Let me know.

Thanks,

Marc
Comment 20 Caolan McNamara 2004-12-10 09:43:27 EST
Yeah, open a seperate "export as PDF" doesn't do right thing against
me. I'd like to know what the story with it is.
Comment 21 Dan Williams 2004-12-10 09:45:32 EST
"Print to PDF"/PDF Converter will generate PostScript, which then gets
run through whatever PS->PDF converter you have set up.

Export to PDF actually writes _PDF_ directly, and you don't have to
rely on sometimes buggy PS->PDF conversions.
Comment 22 Marc Schwartz 2004-12-10 10:04:10 EST
OK.  Bug # 142535
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=142535) has been
created. I also included four attachments, including the EPS file, the
Writer file and two PDFs created using each methodology to show the
difference.

Dan, thanks for the clarification on the mechanism.
Comment 23 Caolan McNamara 2005-01-27 11:46:21 EST
in e.g. 1.1.3 spadmin is available as /usr/lib/ooo-1.1/program/spadmin.bin so
odd stuff can be configured that way
Comment 24 Miguel Freitas 2005-02-02 09:44:46 EST
Caolan, spadmin being available at the rpm is only part of the problem.

Since redhat rpms use OOoCUPS patch from the ooo-build, the "old stuff" support
(e.g. spadmin-configured printers) is removed.

I've just tested on an updated FC3 station (OO 1.1.3) and I can create a generic
printer with the /usr/lib/ooo-1.1/program/spadmin.bin you said, but the printer
doesn't appear at the print dialog.
Comment 25 Marc Schwartz 2005-02-02 09:57:27 EST
That is a known bug:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=146328

Note You need to log in before you can comment on or make changes to this bug.