Bug 1247165 - [hosted-engine] deployment with OVA fails - Cannot acquire host id / Sanlock lockspace add failure
[hosted-engine] deployment with OVA fails - Cannot acquire host id / Sanlock...
Status: CLOSED DUPLICATE of bug 1242448
Product: oVirt
Classification: Community
Component: ovirt-hosted-engine-setup (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.6.0
Assigned To: Simone Tiraboschi
meital avital
: Regression
Depends On:
Blocks: 1205663
  Show dependency treegraph
 
Reported: 2015-07-27 09:33 EDT by Jiri Belka
Modified: 2015-07-28 03:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 03:52:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport-dell-r210ii-13.rhev.lab.eng.brq.redhat.com-20150727152049.tar.xz (5.54 MB, application/x-xz)
2015-07-27 09:33 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2015-07-27 09:33:58 EDT
Created attachment 1056566 [details]
sosreport-dell-r210ii-13.rhev.lab.eng.brq.redhat.com-20150727152049.tar.xz

Description of problem:
(Not using ISCSI thus marking this one as dup for BZ1225366)

...
[ INFO  ] Creating Storage Pool
[ ERROR ] Failed to execute stage 'Misc configuration': Cannot acquire host id: ('60bbd484-9211-40d2-abb9-36aa20014e3e', SanlockException(19, 'Sanlock lockspace add failure', 'No such device'))
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20150727151621.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

[root@dell-r210ii-13 ~]# cat /var/log/sanlock.log 
2015-07-27 14:52:57+0200 4677 [29413]: sanlock daemon started 3.2.2 host b16bb305-aae6-4378-8686-1a7eae65f892.dell-r210i
2015-07-27 15:01:41+0200 5201 [29417]: s1 lockspace 2e1517f6-426e-4afc-b577-884042a2e903:250:/rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpZDCSFe/2e1517f6-426e-4afc-b577-884042a2e903/dom_md/ids:0
2015-07-27 15:01:41+0200 5201 [31026]: open error -13 /rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpZDCSFe/2e1517f6-426e-4afc-b577-884042a2e903/dom_md/ids
2015-07-27 15:01:41+0200 5201 [31026]: s1 open_disk /rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpZDCSFe/2e1517f6-426e-4afc-b577-884042a2e903/dom_md/ids error -13
2015-07-27 15:01:42+0200 5202 [29417]: s1 add_lockspace fail result -19
2015-07-27 15:11:18+0200 25 [905]: sanlock daemon started 3.2.2 host 53d4a404-8ff3-4d35-a12e-facf3534d23a.dell-r210i
2015-07-27 15:16:20+0200 328 [927]: s1 lockspace 60bbd484-9211-40d2-abb9-36aa20014e3e:250:/rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpOw__YI1/60bbd484-9211-40d2-abb9-36aa20014e3e/dom_md/ids:0
2015-07-27 15:16:20+0200 328 [3667]: open error -13 /rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpOw__YI1/60bbd484-9211-40d2-abb9-36aa20014e3e/dom_md/ids
2015-07-27 15:16:20+0200 328 [3667]: s1 open_disk /rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpOw__YI1/60bbd484-9211-40d2-abb9-36aa20014e3e/dom_md/ids error -13
2015-07-27 15:16:21+0200 329 [927]: s1 add_lockspace fail result -19


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.0-0.0.master.20150623153111.git68138d4.el7.noarch
sanlock-3.2.2-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. hosted-engine --deploy and use disk/automatically discovered OVA file
2.
3.

Actual results:
fail on san issue

Expected results:
should work

Additional info:
Comment 1 Simone Tiraboschi 2015-07-28 03:52:29 EDT

*** This bug has been marked as a duplicate of bug 1242448 ***

Note You need to log in before you can comment on or make changes to this bug.