Bug 1247182 - RFE: enable the use of LaTeX within inkscape
RFE: enable the use of LaTeX within inkscape
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On: 1183335 1247187
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 09:58 EDT by Jonathan Underwood
Modified: 2015-08-04 11:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-04 11:44:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch specfile to add -latex subpackage (1.41 KB, patch)
2015-07-27 12:01 EDT, Jonathan Underwood
no flags Details | Diff
Patch to add wek deps for Latex functionality (1.02 KB, patch)
2015-07-27 12:22 EDT, Jonathan Underwood
no flags Details | Diff

  None (edit)
Description Jonathan Underwood 2015-07-27 09:58:54 EDT
Description of problem:
For sometime now, Inkscape has had the built in ability to embed latex input into svg documents. This functionality is available from the Extensions->Render->LaTeX menu item. However, this item is only visible if pstoedit is detected on the system, and the functionality is only present if the correct texlive dependencies are installed. However, for a user, finding the right incantation of packages to install to get this working is ridiculously difficult - none of the packages are currently dependencies of inkscape. This functionality comes from the file:

/usr/share/inkscape/extensions/eqtexsvg.py

Since we probably don't want to bloat the dependencies of the main inkscape package, what I propose is adding a sub-package to inkscape called inkscape-latex which pulls in the required deps to get this working. I am actually still trying to get this functionality working on my F22 system, but so far I know that the requirements include:

pstoedit
texlive-amsmath
texlive-amsfonts
tex-latex-bin
texlive-dvips-bin
Comment 1 Jonathan Underwood 2015-07-27 11:44:53 EDT
Alternatively, this might be a good use of the new soft dependencies in rpm for F24 and later, rather than a sub-package.
Comment 2 Jonathan Underwood 2015-07-27 12:01:30 EDT
Created attachment 1056671 [details]
Patch specfile to add -latex subpackage

This is what adding a sub-package would end up looking like.
Comment 3 Jonathan Underwood 2015-07-27 12:22:19 EDT
Created attachment 1056681 [details]
Patch to add wek deps for Latex functionality

This is what it would look like using weak deps.
Comment 4 Gwyn Ciesla 2015-08-04 10:29:06 EDT
I think I like the weak deps version.  Have you finalized the list of deps?
Comment 5 Jonathan Underwood 2015-08-04 11:11:32 EDT
As far as I can tell, the list in the patch is correct.
Comment 6 Jonathan Underwood 2015-08-04 11:17:21 EDT
ps. I've applied to co-maintain the inkscape package - if you're happy for me to do so, could you approve that. Thanks.
Comment 7 Gwyn Ciesla 2015-08-04 11:32:40 EDT
Done, go ahead and commit, use your powers only for good, etc, etc. :)  And thank you!
Comment 8 Jonathan Underwood 2015-08-04 11:44:15 EDT
Great thanks, applied to rawhide and f23 and builds pushed.

Note You need to log in before you can comment on or make changes to this bug.