This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247187 - Missing plot-svg support
Missing plot-svg support
Status: CLOSED DUPLICATE of bug 1183335
Product: Fedora
Classification: Fedora
Component: pstoedit (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1247182
  Show dependency treegraph
 
Reported: 2015-07-27 10:10 EDT by Jonathan Underwood
Modified: 2015-07-27 10:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-27 10:58:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from upstream tracker to correctly load plugins (6.16 KB, patch)
2015-07-27 10:19 EDT, Jonathan Underwood
no flags Details | Diff

  None (edit)
Description Jonathan Underwood 2015-07-27 10:10:54 EDT
Description of problem:
inkscape has a plugin to allow latex input to be rendered in svg files. This makes use of pstoedit to turn a ps file (produced from a latex fragment) into an svg. See file /usr/share/inkscape/extensions/eqtexsvg.py. The pstoedit command ran by this script looks like:

# pstoedit -f plot-svg -dt -ssp eq.ps eq.svg

which at the moment results in:

pstoedit: version 3.70 / DLL interface 108 (built: Jan  5 2015 - release build - g++ 4.9.2 20141217 (Red Hat 4.9.2-3) - 64-bit) : Copyright (C) 1993 - 2014 Wolfgang Glunz
Unsupported output format plot-svg
Available formats :
	psf:			.fps:	Flattened PostScript (no curves) 	(built-in)
-------------------------------------------
	ps:			.spsc:	Simplified PostScript with curves 	(built-in)
-------------------------------------------
	debug:			.dbg:	for test purposes 	(built-in)
-------------------------------------------
	dump:			.dbg:	for test purposes (same as debug) 	(built-in)
-------------------------------------------
	gs:			.gs:	any device that Ghostscript provides - use gs:format, e.g. gs:pdfwrite 	(built-in)
-------------------------------------------
	ps2ai:			.ai:	Adobe Illustrator via ps2ai.ps of Ghostscript 	(built-in)
-------------------------------------------

And so it seems that svg and plot-svg support has been lost somehow.

Version-Release number of selected component (if applicable):
pstoedit-3.70-1.fc22.x86_64

How reproducible:
Everytime
Comment 1 Jonathan Underwood 2015-07-27 10:17:24 EDT
There seems to be a patch in the upstream tracker for this:

http://sourceforge.net/p/pstoedit/bugs/19/
Comment 2 Jonathan Underwood 2015-07-27 10:19:21 EDT
Created attachment 1056592 [details]
Patch from upstream tracker to correctly load plugins
Comment 3 Jonathan Underwood 2015-07-27 10:58:59 EDT

*** This bug has been marked as a duplicate of bug 1183335 ***

Note You need to log in before you can comment on or make changes to this bug.