Bug 1247404 - [RFE] Improve fusor-installer network validation
[RFE] Improve fusor-installer network validation
Status: CLOSED DUPLICATE of bug 1198648
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHCI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Jason Montleon
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 18:49 EDT by Thom Carlin
Modified: 2016-04-29 12:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 11:46:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-07-27 18:49:49 EDT
Description of enhancement:

For the networking questions in fusor-installer, add additional sanity checks.

Version-Release number of selected component (if applicable):

RHCI 6.0, ISO Media ID 1437667080.278333

Additional info:

The potential changes fall into 2 classes:
A) Validation of the individual item
B) Validation between multiple items.  This could potentially be done as an optional step or at the beginning of "Proceed with configuration"

Some ideas:
1) Verify IP address, network mask, and address range all make sense together
2) Verify DHCP range end >= DHCP range start
3) Verify formats more specifically.  192.168.1.1.1 was accepted without complaint
Comment 1 John Matthews 2015-08-12 11:46:27 EDT

*** This bug has been marked as a duplicate of bug 1198648 ***

Note You need to log in before you can comment on or make changes to this bug.