Bug 1247766 - dnf logrotate.d rotates logs too fast in many cases
dnf logrotate.d rotates logs too fast in many cases
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 16:02 EDT by Chris Siebenmann
Modified: 2015-10-21 09:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.1.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 19:19:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Siebenmann 2015-07-28 16:02:22 EDT
Description of problem:

Dnf's currently shipped /etc/logrotate.d/dnf specifies 'maxsize 30k'.
In many cases this causes *daily* rotation of DNF logfiles (because dnf
logs a lot of debugging information to eg /var/log/dnf.log). However the
dnf logrotate leaves the /etc/logrotate.conf 'rotate 4' setting unchanged,
resulting in effectively keeping only four days of logs.

The standard /etc/logrotate.conf settings of 'weekly' plus 'rotate 4'
is intended to keep four weeks of logs around. Dnf should respect these
settings one way or another, either by removing its own 'maxsize' and
'yearly' settings and relying on logrotate.conf for weekly rotation,
or by expicitly specifying long enough 'rotate N' settings so that it
keeps four weeks of logs with the de facto daily log rotation.

My personal view is that dnf should take the first option. I don't
see why dnf has a particularly strong reason to override the normal
logrotate.conf settings, especially since local system administrators
may want to change them to eg lengthen all log retention times.

Version-Release number of selected component (if applicable):

dnf-1.0.1-2.fc22.noarch
dnf-conf-1.0.1-2.fc22.noarch
Comment 1 Honza Silhan 2015-08-11 07:52:58 EDT
Thanks for the report. We can do that.
Comment 3 Fedora Update System 2015-09-01 05:51:51 EDT
dnf-plugins-core-0.1.11-1.fc23 dnf-1.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 4 Fedora Update System 2015-09-01 16:22:32 EDT
dnf-1.1.1-1.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf dnf-plugins-core'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 5 Fedora Update System 2015-09-08 08:38:46 EDT
dnf-1.1.1-2.fc22 dnf-plugins-core-0.1.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744
Comment 6 Fedora Update System 2015-09-08 08:38:54 EDT
dnf-1.1.1-2.fc22 dnf-plugins-core-0.1.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744
Comment 7 Fedora Update System 2015-09-08 08:39:56 EDT
dnf-1.1.1-2.fc23 dnf-plugins-core-0.1.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 8 Fedora Update System 2015-09-08 13:51:54 EDT
dnf-1.1.1-2.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf dnf-plugins-core'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743
Comment 9 Fedora Update System 2015-09-08 17:26:22 EDT
dnf-1.1.1-2.fc22, dnf-plugins-core-0.1.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf-plugins-core dnf'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744
Comment 10 Fedora Update System 2015-09-09 19:19:00 EDT
dnf-1.1.1-2.fc22, dnf-plugins-core-0.1.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-09-23 00:12:04 EDT
dnf-1.1.1-2.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.