Bug 1271676 - don't rotate /var/log/dnf.rpm.log weekly
don't rotate /var/log/dnf.rpm.log weekly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 09:44 EDT by Harald Reindl
Modified: 2016-01-18 07:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 07:13:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2015-10-14 09:44:14 EDT
"/var/log/dnf.rpm.log" rotate weekly? 
seriously?

for many years "yum.log" was rotated *yearly* which is not a problem and gives a history especially on production servers, well, it was until someone touched it for fixing things which ain't broken (https://bugzilla.redhat.com/show_bug.cgi?id=1231977)

frankly there are people which need compressed logs not wasting any relevant space

[root@buildserver:~]$ cat /etc/logrotate.d/dnf
/var/log/dnf.log {
    missingok
    notifempty
    rotate 4
    weekly
    create 0600 root root
}

/var/log/dnf.librepo.log {
    missingok
    notifempty
    rotate 4
    weekly
    create 0600 root root
}

/var/log/dnf.rpm.log {
    missingok
    notifempty
    rotate 4
    weekly
    create 0600 root root
}

/var/log/dnf.plugin.log {
    missingok
    notifempty
    rotate 4
    weekly
    create 0600 root root
}

/var/log/hawkey.log {
    missingok
    notifempty
    rotate 4
    weekly
    create 0600 root root
}
Comment 1 Honza Silhan 2015-10-21 09:42:22 EDT
So what do you suggest? This just wastes resources of the development to always change unimportant parameters (bug 1247766).
Comment 2 Harald Reindl 2015-10-21 09:47:01 EDT
unimportant parameters?

it wastes also my ressoucres that i need to backup logs which where available for a whole year when i have to write twice a year a reporting about my admin activities

frankly you could have saved a lot of development ressources by not making so much uneeded behavior changes in DNF compare to YUM and to be honest from all what i see the whole DNF development time could have been saved when i permanently have to use yum-deprecated and yum-utils for my work because DNF obviously works only for the ordianry user confirming "yes install updates"
Comment 3 Sergio Monteiro Basto 2015-11-07 14:59:13 EST
I prefer  configuration of Fedora 20 with:
maxsize 30k 
and 
yearly

why you change to  rotate 4,weekly, this give us one month of logs , not good for me .
Comment 4 Harald Reindl 2015-11-07 15:17:26 EST
why maxsize 30k?

that change fucked up having the whole year of update/install logs in yum
https://bugzilla.redhat.com/show_bug.cgi?id=1231977
Comment 5 Harald Reindl 2015-12-27 05:38:20 EST
i prefer making it %config(noreplace) so i can fix it myself without get it overwritten everytime a random update comes and we are done here
Comment 6 Sergio Monteiro Basto 2015-12-27 19:12:28 EST
(In reply to Harald Reindl from comment #5)
> i prefer making it %config(noreplace) so i can fix it myself without get it
> overwritten everytime a random update comes and we are done here

I agree please use something like : 

https://pkgs.fedoraproject.org/cgit/logrotate.git/tree/logrotate.spec#n80
Comment 7 Honza Silhan 2016-01-18 07:13:48 EST
Parameters of logs are subjective. You are able to change them but we have found the params that fit our needs - users can still attach logs to bug reports when we request them. This is a compromise so the logs don't not disappear before we request them in bug report and while not wasting so much space on the disk.

The spec already contains: `%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}`

Note You need to log in before you can comment on or make changes to this bug.