Bug 1247930 - rpc: check for unprivileged port should start at 1024 and not beyond 1024
rpc: check for unprivileged port should start at 1024 and not beyond 1024
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
: Reopened
Depends On:
Blocks: 1248461 1248450
  Show dependency treegraph
 
Reported: 2015-07-29 05:20 EDT by Milind Changire
Modified: 2016-06-16 09:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1248450 1248461 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2015-07-29 05:20:27 EDT
Description of problem:
rpc/rpc-lib/src/rpcsvc.c::rpcsvc_handle_rpc_call()
check for unprivileged port > 1024 should be changed to port >= 1024


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-07-30 04:18:28 EDT
REVIEW: http://review.gluster.org/11788 (rpc: check for unprivileged port should start at 1024) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Anand Avati 2015-07-30 06:30:14 EDT
REVIEW: http://review.gluster.org/11804 (rpc: check for unprivileged port should start at 1024) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 3 Nagaprasad Sathyanarayana 2015-10-25 11:20:18 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 4 Niels de Vos 2016-06-16 09:27:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.